php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71272 i disabled hugepage use --disable-huge-code-pages not effect
Submitted: 2016-01-04 09:47 UTC Modified: 2016-03-22 11:52 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: svei at vip dot qq dot com Assigned: jpauli (profile)
Status: Closed Package: opcache
PHP Version: 7.0.1 OS: Linux version 2.6.33.15
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: svei at vip dot qq dot com
New email:
PHP Version: OS:

 

 [2016-01-04 09:47 UTC] svei at vip dot qq dot com
Description:
------------
compile my php use --disable-huge-code-pages 
and disabled opcache
 ~ #php -m
[PHP Modules]
bcmath
Core
curl
date
dom
filter
gd
gmp
hash
iconv
json
libxml
pcre
posix
Reflection
session
SimpleXML
SPL
standard

[Zend Modules]


because i don't want to use hugepages
but this not effect
when i run test script 
the hugepages in /proc/meminfo was reduce 
before i run my test script

~ #cat /proc/meminfo | grep Huge
HugePages_Total:   11230
HugePages_Free:        5
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB

the HugePages_Free is 5


Test script:
---------------
<?php
sleep(10);


Expected result:
----------------
 ~ #cat /proc/meminfo | grep Huge
HugePages_Total:   11230
HugePages_Free:        5
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB

the HugePages_Free not change 

Actual result:
--------------
~ #cat /proc/meminfo | grep Huge
HugePages_Total:   11230
HugePages_Free:        4
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB

the HugePages_Free is chane to 4


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-04 09:55 UTC] nikic@php.net
The --disable-huge-code-pages configure option, as the name implies, disables use of huge pages for the text segment. This does not impact the use of huge pages by the allocator.
 [2016-01-04 11:19 UTC] svein at vip dot qq dot com
Is there a way to disable the allocator to use huge pages?
 [2016-03-22 11:52 UTC] jpauli@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: jpauli
 [2016-03-22 11:52 UTC] jpauli@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

https://github.com/php/php-src/commit/945a661912612cdecd221cd126feda7d4335c33c was commited.

Should be part of 7.0.5 release.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 05:05:46 2022 UTC