php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #71265 Call to undefined method Thread::globally()
Submitted: 2016-01-02 23:39 UTC Modified: 2017-05-10 11:57 UTC
Votes:5
Avg. Score:3.6 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:1 (33.3%)
From: konstantinos at wgr dot gr Assigned: peehaa (profile)
Status: Closed Package: pthreads (PECL)
PHP Version: 7.0.1 OS: Ubuntu
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: konstantinos at wgr dot gr
New email:
PHP Version: OS:

 

 [2016-01-02 23:39 UTC] konstantinos at wgr dot gr
Description:
------------
---
From manual page: http://www.php.net/thread.globally
---

Although threads are working the static method Thread::globally appears not even exists with a fatal error “Call to undefined method Thread::globally()”. The code tested is the code from the example #1 in http://php.net/thread.globally . 

Test script:
---------------
http://php.net/thread.globally


Patches

pthreads-php-7-0-1 (last revision 2016-01-02 23:47 UTC by konstantinos at wgr dot gr)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-15 12:46 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2016-01-15 12:46 UTC] cmb@php.net
As pointed out in the Github repos' README[1] the documentation
has not yet been updated for PHP 7/pthreads 3. And indeed,
Thread::globally() has been removed as of pthreads 3.0.0.

[1] <https://github.com/krakjoe/pthreads/blob/master/README.md>
 [2017-05-10 11:57 UTC] peehaa@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: peehaa
 [2017-05-10 11:57 UTC] peehaa@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Jul 28 17:01:24 2021 UTC