php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71232 outdated extension APIs for PHP 7.0.1 Windows build
Submitted: 2015-12-28 20:37 UTC Modified: 2016-01-20 13:14 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jurchiks101 at gmail dot com Assigned:
Status: Not a bug Package: Win32API related
PHP Version: 7.0.1 OS: Windows 7 X64
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jurchiks101 at gmail dot com
New email:
PHP Version: OS:

 

 [2015-12-28 20:37 UTC] jurchiks101 at gmail dot com
Description:
------------
I'm trying to run Apache 2.4 and PHP 7.0.1 on my Windows 7 x64 machine. When I start up the Apache service, the Apache error log contains these messages:
PHP Warning:  PHP Startup: curl: Unable to initialize module\nModule compiled with module API=20131226\nPHP    compiled with module API=20151012\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: fileinfo: Unable to initialize module\nModule compiled with module API=20131226\nPHP    compiled with module API=20151012\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: intl: Unable to initialize module\nModule compiled with module API=20131226\nPHP    compiled with module API=20151012\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: mbstring: Unable to initialize module\nModule compiled with module API=20131226\nPHP    compiled with module API=20151012\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: mysqli: Unable to initialize module\nModule compiled with module API=20131226\nPHP    compiled with module API=20151012\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: openssl: Unable to initialize module\nModule compiled with module API=20131226\nPHP    compiled with module API=20151012\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: pdo_mysql: Unable to initialize module\nModule compiled with module API=20131226\nPHP    compiled with module API=20151012\nThese options need to match\n in Unknown on line 0
PHP Warning:  PHP Startup: soap: Unable to initialize module\nModule compiled with module API=20131226\nPHP    compiled with module API=20151012\nThese options need to match\n in Unknown on line 0

This is a fresh download from http://windows.php.net/download/, it's "VC14 x64 Thread Safe (2015-Dec-17 00:17:17)".
All I have done in php.ini is set extension_dir="ext" (required, otherwise it tries to load them from C:/php/) and enabled these extensions that fail to load, no other changes.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-06 00:20 UTC] jurchiks101 at gmail dot com
I also tried the QA release of 7.0.2RC1 
VC14 x64 Thread Safe (2015-Dec-23 05:30:48)
And it had the exact same problem.
It looks like the person who compiles these doesn't even check if they work.
 [2016-01-07 17:36 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2016-01-07 17:36 UTC] ab@php.net
Thanks for the report. ZEND_EXTENSION_API_NO 20131226 corresponds to PHP 5.6. This means the extensions DLLs are not loaded from the PHP 7 distribution. Please set an absolute path in the extension_dir directive. Also please be sure using Apache compiled with VC14.

Thanks.
 [2016-01-07 22:51 UTC] jurchiks101 at gmail dot com
It should treat extension_dir="ext" as a relative directory. It's just a logical expectation that it would.
 [2016-01-20 06:00 UTC] mik2149 at gmail dot com
http: Unable to initialize module\nModule compiled with module API=20131226\nPHP    compiled with module API=20151012\nThese options need to match\n in Unknown on line 0

Apache 2.4 windows 7 x 64 error occurs with 3 extension needed for HttpResponse
error 
Type: Error
Message: Class 'HttpResponse' not found

extension=php_raphf.dll
extension=php_propro.dll
extension=php_http.dll

it seems that they are not complied with php 7.0.1
 [2016-01-20 12:47 UTC] jurchiks101 at gmail dot com
@mik -
https://pecl.php.net/package/raphf
https://pecl.php.net/package/propro
https://pecl.php.net/package/pecl_http
Look under Dependencies, they all require PHP 7+. You just need to update your libraries.
 [2016-01-20 13:14 UTC] mike@php.net
When you're looking for HttpResponse, that means you're using pecl_http-v1, which only works with PHP-5.4 or older.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 20 17:03:35 2021 UTC