php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71194 Unable to load dynamic library
Submitted: 2015-12-22 06:47 UTC Modified: 2016-04-10 18:05 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: tonyd_g at 126 dot com Assigned:
Status: Not a bug Package: intl (PECL)
PHP Version: 5.5.30 OS: mac ox 10.11
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tonyd_g at 126 dot com
New email:
PHP Version: OS:

 

 [2015-12-22 06:47 UTC] tonyd_g at 126 dot com
Description:
------------
PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20121212/intl.so' - dlopen(/usr/lib/php/extensions/no-debug-non-zts-20121212/intl.so, 9): Library not loaded: libicui18n.51.dylib
  Referenced from: /usr/lib/php/extensions/no-debug-non-zts-20121212/intl.so
  Reason: unsafe use of relative rpath libicui18n.51.dylib in /usr/lib/php/extensions/no-debug-non-zts-20121212/intl.so with restricted binary in Unknown on line 0



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-04-10 18:05 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2016-04-10 18:05 UTC] ab@php.net
Thanks for the report. As per the error message, it is related to the builds of ICU on your system, not to PHP.

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jan 23 04:01:24 2020 UTC