php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71156 Session problem
Submitted: 2015-12-18 09:52 UTC Modified: 2015-12-25 08:13 UTC
From: sohorev at gmail dot com Assigned:
Status: Closed Package: Session related
PHP Version: 7.0.1 OS: Ubuntu 14.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sohorev at gmail dot com
New email:
PHP Version: OS:

 

 [2015-12-18 09:52 UTC] sohorev at gmail dot com
Description:
------------
I am use a zend framework version 1 and this framework have a class Zend_Session_Namespace with code:
<code>
        if (!isset($_SESSION['__ZF'])) {
            return; // no further processing needed
        }
</code>
And this code throw exception: Zend_Session_Exception with message: 
The session has already been started.  The session id must be set first.

I am using two browsers:
in firefox - all ok
in opera I have this bug


On php 5.6 this code work normally

Test script:
---------------
        if (!isset($_SESSION['__ZF'])) {
            return; // no further processing needed
        }



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-18 10:05 UTC] requinix@php.net
-Status: Open +Status: Feedback
 [2015-12-18 10:05 UTC] requinix@php.net
Please file a bug report with the ZF1 project - after verifying there isn't already a bug for this problem, of course.
https://github.com/zendframework/zf1/issues

If they can confirm this is a bug with PHP then they'll probably be able to provide more information.
 [2015-12-18 10:33 UTC] sohorev at gmail dot com
-Status: Feedback +Status: Open
 [2015-12-18 10:33 UTC] sohorev at gmail dot com
submitted: https://github.com/zendframework/zf1/issues/662
 [2015-12-25 08:13 UTC] sohorev at gmail dot com
-Status: Open +Status: Closed
 [2015-12-25 08:13 UTC] sohorev at gmail dot com
I'm sorry, but it is not a bug. Problem related with parameter session.save_handler
 [2015-12-25 08:15 UTC] sohorev at gmail dot com
not session.save_handler
related with session.hash_bits_per_character parameter
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Nov 29 22:05:54 2022 UTC