php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71139 pecl memcached fails to build with php-7.x
Submitted: 2015-12-16 16:12 UTC Modified: 2016-03-26 20:37 UTC
Votes:5
Avg. Score:4.8 ± 0.4
Reproduced:4 of 5 (80.0%)
Same Version:3 (75.0%)
Same OS:4 (100.0%)
From: Vincent dot Riera at imgtec dot com Assigned: krakjoe (profile)
Status: Closed Package: memcached (PECL)
PHP Version: 7.0.0 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Vincent dot Riera at imgtec dot com
New email:
PHP Version: OS:

 

 [2015-12-16 16:12 UTC] Vincent dot Riera at imgtec dot com
Description:
------------
Fails to build with PHP-7.x (I have tried with 7.0.1).

Actual result:
--------------
php-memcached-2.2.0/php_memcached_private.h:44:40: fatal error: ext/standard/php_smart_str.h: No such file or directory
 #include <ext/standard/php_smart_str.h>
                                        ^
compilation terminated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-17 07:43 UTC] bertrand at presles dot fr
This is because PECL sources are for PHP 5.

You can build memcached extension perfectly from sources on GIT "php7" branch (cf https://github.com/php-memcached-dev/php-memcached/tree/php7).
 [2015-12-17 10:46 UTC] Vincent dot Riera at imgtec dot com
Do you know if there is a plan to release a new version compatible with PHP 7?
 [2015-12-19 15:59 UTC] hallboy3 at gmail dot com
Hi,
Maybe You has multiple PHP versions installed and don't specify which in the build. Try to build with command like this 

/opt/php70/bin/phpize
./configure --with-php-config=/opt/php70/bin/php-config
 [2016-03-26 20:37 UTC] krakjoe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: krakjoe
 [2016-03-26 20:37 UTC] krakjoe@php.net
This is no longer relevant, there is a working branch for php7+memcached now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Sep 27 23:01:28 2020 UTC