php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71131 imap_open password umlauts
Submitted: 2015-12-15 22:48 UTC Modified: 2015-12-16 17:48 UTC
From: alex at belogy dot de Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 5.6.16 OS: Linux and Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alex at belogy dot de
New email:
PHP Version: OS:

 

 [2015-12-15 22:48 UTC] alex at belogy dot de
Description:
------------
imap_open fails to authenticate if the password contains german umlauts.

Test script:
---------------
imap_open('{mail.example.com:993/imap/ssl}', 'user@example.com', 'passwordwithäöü'))


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-16 17:48 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2015-12-16 17:48 UTC] ab@php.net
Thanks for the report. PHP only sends the chars that are given. Please check that the correct charset is used. FE you stored the password is UTF-8 and then don't send it in latin1.

Thanks.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 13:03:35 2021 UTC