php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71083 Does not compile for PHP 7.0.0
Submitted: 2015-12-10 18:42 UTC Modified: 2016-08-19 00:25 UTC
Votes:23
Avg. Score:4.9 ± 0.4
Reproduced:22 of 22 (100.0%)
Same Version:16 (72.7%)
Same OS:3 (13.6%)
From: jrpozo at conclase dot net Assigned: ohill (profile)
Status: Closed Package: geoip (PECL)
PHP Version: 7.0.0 OS: Linux CentOS release 6.7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jrpozo at conclase dot net
New email:
PHP Version: OS:

 

 [2015-12-10 18:42 UTC] jrpozo at conclase dot net
Description:
------------
Does not compile for PHP 7.0.0



Actual result:
--------------
# ./configure --with-php-config=/usr/local/php-7.0.0/bin/php-config --with-geoip=/usr/local/GeoIP
[...]
creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h

# make
/bin/sh /usr/local/src/php/local/geoip-1.1.0/libtool --mode=compile cc  -I. -I/usr/local/src/php/local/geoip-1.1.0 -DPHP_ATOM_INC -I/usr/local/src/php/local/geoip-1.1.0/include -I/usr/local/src/php/local/geoip-1.1.0/main -I/usr/local/src/php/local/geoip-1.1.0 -I/usr/local/php-7.0.0/include/php -I/usr/local/php-7.0.0/include/php/main -I/usr/local/php-7.0.0/include/php/TSRM -I/usr/local/php-7.0.0/include/php/Zend -I/usr/local/php-7.0.0/include/php/ext -I/usr/local/php-7.0.0/include/php/ext/date/lib -I/usr/local/GeoIP/include  -DHAVE_CONFIG_H  -g -O2   -c /usr/local/src/php/local/geoip-1.1.0/geoip.c -o geoip.lo
mkdir .libs
 cc -I. -I/usr/local/src/php/local/geoip-1.1.0 -DPHP_ATOM_INC -I/usr/local/src/php/local/geoip-1.1.0/include -I/usr/local/src/php/local/geoip-1.1.0/main -I/usr/local/src/php/local/geoip-1.1.0 -I/usr/local/php-7.0.0/include/php -I/usr/local/php-7.0.0/include/php/main -I/usr/local/php-7.0.0/include/php/TSRM -I/usr/local/php-7.0.0/include/php/Zend -I/usr/local/php-7.0.0/include/php/ext -I/usr/local/php-7.0.0/include/php/ext/date/lib -I/usr/local/GeoIP/include -DHAVE_CONFIG_H -g -O2 -c /usr/local/src/php/local/geoip-1.1.0/geoip.c  -fPIC -DPIC -o .libs/geoip.o
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘OnUpdateDirectory’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:132: warning: passing argument 1 of ‘geoip_change_custom_directory’ from incompatible pointer type
/usr/local/src/php/local/geoip-1.1.0/geoip.c:102: note: expected ‘char *’ but argument is of type ‘struct zend_string *’
/usr/local/src/php/local/geoip-1.1.0/geoip.c:136: error: ‘new_value_length’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:136: error: (Each undeclared identifier is reported only once
/usr/local/src/php/local/geoip-1.1.0/geoip.c:136: error: for each function it appears in.)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:136: warning: passing argument 6 of ‘OnUpdateString’ makes integer from pointer without a cast
/usr/local/php-7.0.0/include/php/Zend/zend_ini.h:162: note: expected ‘int’ but argument is of type ‘void *’
/usr/local/src/php/local/geoip-1.1.0/geoip.c:136: error: too many arguments to function ‘OnUpdateString’
/usr/local/src/php/local/geoip-1.1.0/geoip.c:285:44: error: macro "RETURN_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_db_filename’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:285: error: ‘RETURN_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:306:74: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_db_get_all_info’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:306: error: ‘add_assoc_string’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:309:60: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c:349:26: error: macro "RETVAL_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_database_info’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:349: error: ‘RETVAL_STRING’ undeclared (first use in this function)
In file included from /usr/local/src/php/local/geoip-1.1.0/geoip.c:382:
/usr/local/src/php/local/geoip-1.1.0/geoip.def:20:1: error: macro "RETURN_STRING" passed 2 arguments, but takes just 1
In file included from /usr/local/src/php/local/geoip-1.1.0/geoip.c:382:
/usr/local/src/php/local/geoip-1.1.0/geoip.def: In function ‘zif_geoip_country_code_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.def:20: error: ‘RETURN_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.def:21:1: error: macro "RETURN_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.def: In function ‘zif_geoip_country_code3_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.def:21: error: ‘RETURN_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.def:22:1: error: macro "RETURN_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.def: In function ‘zif_geoip_country_name_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.def:22: error: ‘RETURN_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:411:54: error: macro "RETURN_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_continent_code_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:411: error: ‘RETURN_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:440:22: error: macro "RETVAL_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_org_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:440: error: ‘RETVAL_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:470:22: error: macro "RETVAL_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_asnum_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:470: error: ‘RETVAL_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:500:22: error: macro "RETVAL_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_domain_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:500: error: ‘RETVAL_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:531:22: error: macro "RETVAL_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_netspeedcell_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:531: error: ‘RETVAL_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:570:110: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_record_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:570: error: ‘add_assoc_string’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:572:104: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c:573:107: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c:574:104: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c:575:86: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c:576:80: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c:577:101: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c:649:72: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_region_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:649: error: ‘add_assoc_string’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:650:60: error: macro "add_assoc_string" passed 4 arguments, but takes just 3
/usr/local/src/php/local/geoip-1.1.0/geoip.c:681:22: error: macro "RETVAL_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_isp_by_name’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:681: error: ‘RETVAL_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:708:37: error: macro "RETURN_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_region_name_by_code’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:708: error: ‘RETURN_STRING’ undeclared (first use in this function)
/usr/local/src/php/local/geoip-1.1.0/geoip.c:736:34: error: macro "RETURN_STRING" passed 2 arguments, but takes just 1
/usr/local/src/php/local/geoip-1.1.0/geoip.c: In function ‘zif_geoip_time_zone_by_country_and_region’:
/usr/local/src/php/local/geoip-1.1.0/geoip.c:736: error: ‘RETURN_STRING’ undeclared (first use in this function)
make: *** [geoip.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-15 09:33 UTC] dgamax at gmail dot com
Same issue with 7.0.2
 [2016-04-14 09:22 UTC] vincent dot riera at imgtec dot com
Same problem with 7.0.5.

Someone ported geoip-1.0.7 to php-7: https://github.com/Zakay/geoip

Perhaps it's worth it to work together or integrate his code into the official geoip.
 [2016-06-28 09:07 UTC] schnederle at futureweb dot at
Hello,
was able to compile latest SVN Trunk without Problems on PHP 7.0.7 ...
--> http://svn.php.net/viewvc/pecl/geoip/trunk/?pathrev=337409
Andreas Schnederle-Wagner
 [2016-07-28 14:07 UTC] cmb@php.net
-Assigned To: +Assigned To: ohill
 [2016-07-28 14:07 UTC] cmb@php.net
Olivier, is a PHP 7 compatible release already scheduled?
 [2016-07-28 14:53 UTC] spam2 at rhsoft dot net
it would be really nice to have a trunk download as tarball on the pecl-page as other packages also offer alpha/beta state versions for people using rpmbuild since svn.php.net offers nowhere useable downloads
 [2016-08-19 00:25 UTC] ohill@php.net
-Status: Assigned +Status: Closed
 [2016-08-19 00:25 UTC] ohill@php.net
Fixed in beta release 1.1.1
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jan 23 05:01:24 2020 UTC