php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71069 PHP 7.0.0 does not seem to obey the --prefix option.
Submitted: 2015-12-09 04:50 UTC Modified: 2015-12-14 04:01 UTC
From: admin at harris-services dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 7.0.0 OS: CentOS 6.7
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: admin at harris-services dot com
New email:
PHP Version: OS:

 

 [2015-12-09 04:50 UTC] admin at harris-services dot com
Description:
------------
http://www.evadrepus.com/test.php

As can be seen by the phpinfo page above I had set the same options that I have in the 5.x branch to do a side by side install of 7.0.0 on my CentOS 6.7 server with cPanel.  When I did a make install on the source, after a configure and make, the install was done to /usr/local/bin/ and not to /opt/php7 as I had set in the configuration options.  While this does not seem to have broken my server, and I was able to still set the needed options on the server to load the new version via a handler, this could break any system where /usr/bin is symlinked to /usr/local/bin.  I am not completely sure if this is intended for the new version but this could cause problems for anyone that has configuration scripts with all of the needed options included so that new minors can be built.

Please bear with me regarding this report, is my first one here and not really sure what other info you may need.

Test script:
---------------
N/A

Expected result:
----------------
This is the settings that were set in the configure stage.

'--prefix=/opt/php7' '--with-config-file-path=/opt/php7/lib' '--with-config-file-scan-dir=/opt/php7/lib/php.ini.d'

Actual result:
--------------
[activating module `php7' in /usr/local/apache/conf/httpd.conf]
Installing shared extensions:     /usr/local/lib/php/extensions/no-debug-non-zts-20151012/
Installing PHP CLI binary:        /usr/local/bin/
Installing PHP CLI man page:      /usr/local/php/man/man1/
Installing phpdbg binary:         /usr/local/bin/
Installing phpdbg man page:       /usr/local/php/man/man1/
Installing PHP CGI binary:        /usr/local/bin/
Installing PHP CGI man page:      /usr/local/php/man/man1/
Installing build environment:     /usr/local/lib/php/build/
Installing header files:          /usr/local/include/php/
Installing helper programs:       /usr/local/bin/
  program: phpize
  program: php-config
Installing man pages:             /usr/local/php/man/man1/
  page: phpize.1
  page: php-config.1
Installing PEAR environment:      /usr/local/lib/php/

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-09 06:20 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2015-12-09 06:20 UTC] rasmus@php.net
No bug here. Copying straight from your phpinfo:

'--prefix=/opt/php7' '--with-config-file-path=/opt/php7/lib' '--with-config-file-scan-dir=/opt/php7/lib/php.ini.d' '--disable-opcache' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-gd-native-ttf' '--enable-intl' '--enable-libxml' '--enable-mbstring' '--enable-pdo=shared' '--enable-soap' '--enable-sockets' '--enable-zip' '--prefix=/usr/local'

Note that you have a 2nd --prefix flag there set to /usr/local. This will override the first one.
 [2015-12-14 04:01 UTC] admin at harris-services dot com
Wow.  I read over the options at least 2 times and missed that.  Thanks!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 02:03:41 2022 UTC