php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71026 3.3.0RC2 does not compile with php 7.0.0
Submitted: 2015-12-04 09:13 UTC Modified: 2015-12-04 18:34 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: cf0hay at gmail dot com Assigned: danack (profile)
Status: Closed Package: imagick (PECL)
PHP Version: 7.0.0 OS: 64bit linux, 64bit php
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: cf0hay at gmail dot com
New email:
PHP Version: OS:

 

 [2015-12-04 09:13 UTC] cf0hay at gmail dot com
Description:
------------
3.3.0RC2 claims php 7.0.0 compatibility, but it doesn't compile.

Expected result:
----------------
"make" should compile without problems.

Actual result:
--------------
For example:

error: macro "ZVAL_STRING" passed 3 arguments, but takes just 2

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-04 18:34 UTC] danack@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: danack
 [2015-12-04 18:34 UTC] danack@php.net
> 3.3.0RC2 claims php 7.0.0 compatibility, 

I don't believe it did.  There is both a <max>7.0.0</max> and <exclude>7.0.0</exclude> to support versions of PHP up to, but not including, 7.

3.4.0RC2 is now available, and that does claim to support 7.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Nov 27 06:05:54 2022 UTC