php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71015 https://www.php.net/ serves invalid SSL certificate
Submitted: 2015-12-03 09:53 UTC Modified: 2015-12-03 14:36 UTC
From: johan at bambuser dot com Assigned:
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: johan at bambuser dot com
New email:
PHP Version: OS:

 

 [2015-12-03 09:53 UTC] johan at bambuser dot com
Description:
------------
When visiting https://www.php.net from Finland I get served an invalid SSL certificate. The https URL is the first result when googling for PHP. The certificate my browser is served is only valid for php.planeetta.net, which is a Finnish hosting provider, so I assume that this problem might not exist on other mirrors.

Expected result:
----------------
I expect that all mirror-servers should serve the correct certificate for the host https://www.php.net


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-03 14:36 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2015-12-03 14:36 UTC] aharvey@php.net
Duplicate of bug #70972.

tl;dr: use https://secure.php.net/ instead; www.php.net intentionally doesn't support HTTPS.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Apr 02 23:01:23 2020 UTC