php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70917 install-pear-nozlib.phar missing (regression to RC6)
Submitted: 2015-11-14 21:22 UTC Modified: 2015-11-15 16:32 UTC
From: bug@php.net Assigned: ab (profile)
Status: Closed Package: *General Issues
PHP Version: 7.0.0RC7 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bug@php.net
New email:
PHP Version: OS:

 

 [2015-11-14 21:22 UTC] bug@php.net
Description:
------------
Tarball is not self-contained:

$ make install
:
Installing man pages:             /tmp/local/php/man/man1/
  page: phpize.1
  page: php-config.1
Installing PEAR environment:      /tmp/local/lib/php/
--2015-11-14 22:12:19--  https://pear.php.net/install-pear-nozlib.phar
Resolving pear.php.net (pear.php.net)... failed: Name or service not known.
wget: unable to resolve host address `pear.php.net'
make: *** [install-pear] Error 4

Regression: #41143 (2007)

Expected result:
----------------
Add install-pear-nozlib.phar to the tarball.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-11-15 13:34 UTC] laruence@php.net
-Assigned To: +Assigned To: tyrael
 [2015-11-15 13:34 UTC] laruence@php.net
@tyrael could you please have a look ?
 [2015-11-15 13:35 UTC] laruence@php.net
-Status: Assigned +Status: Feedback -Assigned To: tyrael +Assigned To:
 [2015-11-15 13:35 UTC] laruence@php.net
hmm, I read it wrongly, seems a network issue?
 [2015-11-15 16:03 UTC] tyrael@php.net
-Assigned To: +Assigned To: ab
 [2015-11-15 16:03 UTC] tyrael@php.net
it seems that the RC7 packages are missing the downloaded install-pear-nozlib.phar.
I can't reproduce the dns issue provided in the report but I guess that was a self-inflicted to point out the lack of install-pear-nozlib.phar in the tarball.

Anatol, do you happen to have the makedist output for RC7? Would be nice knowing why did the pear download fail or fix it if there is some persistent problem so the next version can have install-pear-nozlib.phar in the tarball.
 [2015-11-15 16:03 UTC] tyrael@php.net
-Status: Feedback +Status: Verified
 [2015-11-15 16:32 UTC] ab@php.net
Unfortunately I've no output anymore. But it seems to be nothing else than the failed host resolution, fe also bug #70832 around the tagging date. So most likely my bad not seeing the download error (and the absence of that phar haven't also affect the end tarball size, unfortunately).

Ferenc, do you think we could add this or similar to the script?

diff --git a/makedist b/makedist
index 5b28dd8..48c6312 100755
--- a/makedist
+++ b/makedist
@@ -119,6 +119,11 @@ sed -i 's,^#ifndef YYTOKENTYPE,#include "zend.h"\n#ifndef YYTOKENTYPE,g' $MY_OLD
 $ECHO_N "makedist: Attempting to download PEAR's phar archive"
 if test ! -x wget; then
        wget https://pear.php.net/install-pear-nozlib.phar -nd -P pear/
+       if [ "x$?" != "x0" ]
+       then
+               $ECHO_N "Pear download failed";
+               exit 7
+       fi
 else
        $ECHO_N "Missing wget binary needed for pear download";
        exit 7

Thanks.
 [2015-11-15 18:04 UTC] ab@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=7819fef345f2ec80c4fea804b350e229af589990
Log: Fixed bug #70917 install-pear-nozlib.phar missing
 [2015-11-15 18:04 UTC] ab@php.net
-Status: Verified +Status: Closed
 [2015-11-20 01:03 UTC] ab@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=27742dc6e8dabf36bee2bbdbc9e2a9be3065db22
Log: Fixed bug #70917 install-pear-nozlib.phar missing
 [2016-07-20 11:35 UTC] davey@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=7819fef345f2ec80c4fea804b350e229af589990
Log: Fixed bug #70917 install-pear-nozlib.phar missing
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Apr 19 00:01:29 2024 UTC