php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70889 SSH2 support missing in 5.6.15?
Submitted: 2015-11-11 10:06 UTC Modified: 2015-12-09 13:51 UTC
From: jeda at infinera dot com Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5.6.15 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jeda at infinera dot com
New email:
PHP Version: OS:

Further comment on this bug is unnecessary.

 

 [2015-11-11 10:06 UTC] jeda at infinera dot com
Description:
------------
In PHP 5.6.15 I am unable to configure & build with ssh2.

configure: WARNING: unrecognized options: --with-ssh2


I looked at the 'configure' file and it's missing SSH2 parameters. Comparing to 5.6.14 configure file, it has SSH2 parameters.


Is this a bug or a change of supported modules? I cannot find any documentation on this change.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-09 13:51 UTC] langemeijer@php.net
-Status: Open +Status: Not a bug -Block user comment: No +Block user comment: Yes
 [2015-12-09 13:51 UTC] langemeijer@php.net
ssh2 has never been included in the PHP source, but is available as an extension distributed as a pecl package: http://pecl.php.net/package/ssh2

See http://www.php.net/manual/en/ssh2.installation.php for more information.

Closing this bugreport as this is not a bug. Please don't use the bugtracker as a support forum.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jul 06 22:01:03 2020 UTC