php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70883 Production php.ini Example doesn't enable ext folder by default
Submitted: 2015-11-09 16:31 UTC Modified: 2015-11-09 18:16 UTC
From: james2432 at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 7.0.0RC6 OS: Windows Server 2012 R2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: james2432 at gmail dot com
New email:
PHP Version: OS:

 

 [2015-11-09 16:31 UTC] james2432 at gmail dot com
Description:
------------
The example production php.ini has extension_dir commented out by default.
This causes php to look in C:\php for extensions (despite being installed else where, in this case: C:\php7\)(see apache log below)

PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\php_bz2.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\php_curl.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\php_gd2.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\php_ldap.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\php_exif.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\php_mysqli.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\php_openssl.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\php_pdo_mysql.dll' - The specified module could not be found.\r\n in Unknown on line 0




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-11-09 18:16 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2015-11-09 18:16 UTC] ab@php.net
Thanks for the report. Yes, you need to set the suitable paths and other options in your php.ini file, otherwise the hardcoded default paths will be used. This is the exected behavior.

Thanks.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 12:05:44 2022 UTC