php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7088 mssql_fetch_row
Submitted: 2000-10-08 12:34 UTC Modified: 2001-06-30 15:36 UTC
From: tcs at cyber dot cs dot ntou dot edu dot tw Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.2 OS: Windows 2000 Server
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tcs at cyber dot cs dot ntou dot edu dot tw
New email:
PHP Version: OS:

 

 [2000-10-08 12:34 UTC] tcs at cyber dot cs dot ntou dot edu dot tw
when fetch a char field,it can not fetch more than 255 char in a field.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-20 16:30 UTC] fmk@php.net
The DB libray from Microsoft does not support the NCHAR datatype. is is converted to and handled as a CHAR with the maximum length of 255 bytes.

Use TEXT type. it will work.

I'll report the error to Microsoft.
 [2000-11-10 01:36 UTC] tcs at cyber dot cs dot ntou dot edu dot tw
Use TEXT can fetch larger then 255 chars.But it still not be able to fetch as long as 2000 chars field.
 [2001-06-30 15:36 UTC] fmk@php.net
This is not a bug in the php extension, but a limmitation in the libraries provides by Microsoft.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 05:05:45 2022 UTC