php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70865 ./configure showing "You have built PHP for Apache's current non-threaded MPM."
Submitted: 2015-11-05 20:43 UTC Modified: 2015-11-10 16:51 UTC
From: jfha73 at gmail dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 7.0.0RC6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jfha73 at gmail dot com
New email:
PHP Version: OS:

 

 [2015-11-05 20:43 UTC] jfha73 at gmail dot com
Description:
------------
./configure is showing:

+--------------------------------------------------------------------+
|                        *** WARNING ***                             |
|                                                                    |
| You have built PHP for Apache's current non-threaded MPM.          |
| If you change Apache to use a threaded MPM you must reconfigure    |
| PHP with --enable-maintainer-zts                                   |
+--------------------------------------------------------------------+
| License:                                                           |
| This software is subject to the PHP License, available in this     |
| distribution in the file LICENSE.  By continuing this installation |
| process, you are bound by the terms of this license agreement.     |
| If you do not agree with the terms of this license, you must abort |
| the installation process at this point.                            |
+--------------------------------------------------------------------+

Even when --enable-maintainer-zts is added and it's not letting mod_mm to be compiled because it needs PHP to be Thread Safe

Expected result:
----------------
compile Thread Safe.

Actual result:
--------------
nts is built even when --enable-maintainer-zts is added

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-11-06 02:39 UTC] laruence@php.net
which apache version/mpm do you use?
 [2015-11-06 13:59 UTC] jfha73 at gmail dot com
2.4.17
 [2015-11-09 22:41 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2015-11-09 22:41 UTC] ab@php.net
It appears that you're using a non thread safe Apache MPM, most likely --with-mpm=prefork. If you want PHP to produce a thread safe Apache PHP module, you'll need either to install mpm_worker or compile Apache --with-mpm=worker, and then use that Apache build to be linked with PHP configured with --enable-maintainer-zts option.

Thanks.
 [2015-11-10 16:51 UTC] jfha73 at gmail dot com
I tried that (installed mpm_worker) but when I tried to run ./configure it said --with-mpm=worker not recognized, I even tried ./buildconfig --force to see if it needed to be put in configure before running it and same thing happened.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Nov 29 11:05:56 2022 UTC