php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70818 Segmentation fault $php_fpm_BIN --daemonize $php_opts
Submitted: 2015-10-30 02:15 UTC Modified: 2015-11-30 02:53 UTC
Votes:4
Avg. Score:4.0 ± 1.0
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:2 (66.7%)
From: nguyentu dot me at outlook dot com Assigned: laruence (profile)
Status: Closed Package: opcache
PHP Version: 7.0.0RC6 OS: CentOS 6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nguyentu dot me at outlook dot com
New email:
PHP Version: OS:

 

 [2015-10-30 02:15 UTC] nguyentu dot me at outlook dot com
Description:
------------
# service php-fpm restart
Gracefully shutting down php-fpm warning, no pid file found - php-fpm is not running ?
Starting php-fpm /etc/init.d/php-fpm: line 53: 22517 Segmentation fault      $php_fpm_BIN --daemonize $php_opts
 failed

Expected result:
----------------
I added this line at the end of php.ini and I cant start php-fpm using "service php-fpm start"

zend_extension=opcache.so

Output:

# service php-fpm start
Gracefully shutting down php-fpm warning, no pid file found - php-fpm is not running ?
Starting php-fpm /etc/init.d/php-fpm: line 53: 22517 Segmentation fault      $php_fpm_BIN --daemonize $php_opts
 failed

I tested on PHP 7 RC4 versions and it worked fine.

Thank you!



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-30 03:12 UTC] laruence@php.net
-Status: Open +Status: Feedback
 [2015-10-30 03:12 UTC] laruence@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2015-10-30 06:43 UTC] nguyentu dot me at outlook dot com
-Status: Feedback +Status: Open
 [2015-10-30 06:43 UTC] nguyentu dot me at outlook dot com
Thank you, sorry this is my first time do this: D

# gdb /usr/local/php7/sbin/php-fpm /tmp/coredump-php-fpm.3805
GNU gdb (GDB) Red Hat Enterprise Linux (7.2-83.el6)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/local/php7/sbin/php-fpm...done.
[New Thread 3805]
Missing separate debuginfo for /usr/local/php7/lib/php/extensions/no-debug-non-zts-20151012/opcache.so
Try: yum --enablerepo='*-debug*' install /usr/lib/debug/.build-id/75/06ddcdd5a6528c53bcb201dfd6058d5218c290
Missing separate debuginfo for
Try: yum --enablerepo='*-debug*' install /usr/lib/debug/.build-id/4b/8e1260ccd7c3d8cc131e84001f7220651617ec
Reading symbols from /lib64/libcrypt-2.12.so...Reading symbols from /usr/lib/debug/lib64/libcrypt-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libcrypt-2.12.so
Reading symbols from /lib64/libresolv-2.12.so...Reading symbols from /usr/lib/debug/lib64/libresolv-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libresolv-2.12.so
Reading symbols from /lib64/libz.so.1.2.3...Reading symbols from /usr/lib/debug/lib64/libz.so.1.2.3.debug...done.
done.
Loaded symbols for /lib64/libz.so.1.2.3
Reading symbols from /lib64/librt-2.12.so...Reading symbols from /usr/lib/debug/lib64/librt-2.12.so.debug...done.
done.
Loaded symbols for /lib64/librt-2.12.so
Reading symbols from /lib64/libm-2.12.so...Reading symbols from /usr/lib/debug/lib64/libm-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libm-2.12.so
Reading symbols from /lib64/libdl-2.12.so...Reading symbols from /usr/lib/debug/lib64/libdl-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libdl-2.12.so
Reading symbols from /lib64/libnsl-2.12.so...Reading symbols from /usr/lib/debug/lib64/libnsl-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libnsl-2.12.so
Reading symbols from /usr/lib64/libxml2.so.2.7.6...Reading symbols from /usr/lib/debug/usr/lib64/libxml2.so.2.7.6.debug...done.
done.
Loaded symbols for /usr/lib64/libxml2.so.2.7.6
Reading symbols from /lib64/libc-2.12.so...Reading symbols from /usr/lib/debug/lib64/libc-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libc-2.12.so
Reading symbols from /lib64/libfreebl3.so...Reading symbols from /usr/lib/debug/lib64/libfreebl3.so.debug...done.
done.
Loaded symbols for /lib64/libfreebl3.so
Reading symbols from /lib64/libpthread-2.12.so...Reading symbols from /usr/lib/debug/lib64/libpthread-2.12.so.debug...done.
[Thread debugging using libthread_db enabled]
done.
Loaded symbols for /lib64/libpthread-2.12.so
Reading symbols from /lib64/ld-2.12.so...Reading symbols from /usr/lib/debug/lib64/ld-2.12.so.debug...done.
done.
Loaded symbols for /lib64/ld-2.12.so
Reading symbols from /usr/local/php7/lib/php/extensions/no-debug-non-zts-20151012/opcache.so...done.
Loaded symbols for /usr/local/php7/lib/php/extensions/no-debug-non-zts-20151012/opcache.so
Core was generated by `/usr/local/php7/sbin/php-fpm --daemonize --fpm-config /usr/local/php7/etc/php-f'.
Program terminated with signal 11, Segmentation fault.
#0  __strcmp_sse42 () at ../sysdeps/x86_64/multiarch/strcmp.S:701
701             movdqa  (%rdi), %xmm2
(gdb) bt
#0  __strcmp_sse42 () at ../sysdeps/x86_64/multiarch/strcmp.S:701
#1  0x00007ff4813d32a9 in accel_find_sapi (extension=<value optimized out>) at /usr/src/php-7.0.0RC6/ext/opcache/ZendAccelerator.c:2355
#2  accel_startup (extension=<value optimized out>) at /usr/src/php-7.0.0RC6/ext/opcache/ZendAccelerator.c:2613
#3  0x00000000006c4cd1 in zend_extension_startup (extension=0x29cc350) at /usr/src/php-7.0.0RC6/Zend/zend_extensions.c:176
#4  0x00000000006ae643 in zend_llist_apply_with_del (l=0xf90340, func=0x6c4cc0 <zend_extension_startup>) at /usr/src/php-7.0.0RC6/Zend/zend_llist.c:171
#5  0x00000000006c4cb7 in zend_startup_extensions () at /usr/src/php-7.0.0RC6/Zend/zend_extensions.c:197
#6  0x000000000065e1a5 in php_module_startup (sf=<value optimized out>, additional_modules=<value optimized out>, num_additional_modules=<value optimized out>)
    at /usr/src/php-7.0.0RC6/main/main.c:2197
#7  0x0000000000756ec5 in php_cgi_startup (sapi_module=<value optimized out>) at /usr/src/php-7.0.0RC6/sapi/fpm/fpm/fpm_main.c:837
#8  0x000000000075773e in main (argc=6, argv=0x7fffb7cdc738) at /usr/src/php-7.0.0RC6/sapi/fpm/fpm/fpm_main.c:1788
 [2015-10-30 07:43 UTC] nguyentu dot me at outlook dot com
With --enable-debug!

# gdb /usr/local/php7/sbin/php-fpm /tmp/coredump-php-fpm.10495
GNU gdb (GDB) Red Hat Enterprise Linux (7.2-83.el6)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/local/php7/sbin/php-fpm...done.
[New Thread 10495]
Missing separate debuginfo for /usr/local/php7/lib/php/extensions/debug-non-zts-20151012/opcache.so
Try: yum --enablerepo='*-debug*' install /usr/lib/debug/.build-id/ac/7df85df073eaff15280f291903e52e4a278133
Missing separate debuginfo for
Try: yum --enablerepo='*-debug*' install /usr/lib/debug/.build-id/4b/8e1260ccd7c3d8cc131e84001f7220651617ec
Reading symbols from /lib64/libcrypt-2.12.so...Reading symbols from /usr/lib/debug/lib64/libcrypt-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libcrypt-2.12.so
Reading symbols from /lib64/libresolv-2.12.so...Reading symbols from /usr/lib/debug/lib64/libresolv-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libresolv-2.12.so
Reading symbols from /lib64/librt-2.12.so...Reading symbols from /usr/lib/debug/lib64/librt-2.12.so.debug...done.
done.
Loaded symbols for /lib64/librt-2.12.so
Reading symbols from /lib64/libm-2.12.so...Reading symbols from /usr/lib/debug/lib64/libm-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libm-2.12.so
Reading symbols from /lib64/libdl-2.12.so...Reading symbols from /usr/lib/debug/lib64/libdl-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libdl-2.12.so
Reading symbols from /lib64/libnsl-2.12.so...Reading symbols from /usr/lib/debug/lib64/libnsl-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libnsl-2.12.so
Reading symbols from /usr/lib64/libxml2.so.2.7.6...Reading symbols from /usr/lib/debug/usr/lib64/libxml2.so.2.7.6.debug...done.
done.
Loaded symbols for /usr/lib64/libxml2.so.2.7.6
Reading symbols from /lib64/libz.so.1.2.3...Reading symbols from /usr/lib/debug/lib64/libz.so.1.2.3.debug...done.
done.
Loaded symbols for /lib64/libz.so.1.2.3
Reading symbols from /lib64/libc-2.12.so...Reading symbols from /usr/lib/debug/lib64/libc-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libc-2.12.so
Reading symbols from /lib64/libfreebl3.so...Reading symbols from /usr/lib/debug/lib64/libfreebl3.so.debug...done.
done.
Loaded symbols for /lib64/libfreebl3.so
Reading symbols from /lib64/libpthread-2.12.so...Reading symbols from /usr/lib/debug/lib64/libpthread-2.12.so.debug...done.
[Thread debugging using libthread_db enabled]
done.
Loaded symbols for /lib64/libpthread-2.12.so
Reading symbols from /lib64/ld-2.12.so...Reading symbols from /usr/lib/debug/lib64/ld-2.12.so.debug...done.
done.
Loaded symbols for /lib64/ld-2.12.so
Reading symbols from /usr/local/php7/lib/php/extensions/debug-non-zts-20151012/opcache.so...done.
Loaded symbols for /usr/local/php7/lib/php/extensions/debug-non-zts-20151012/opcache.so
Core was generated by `/usr/local/php7/sbin/php-fpm --daemonize --fpm-config /usr/local/php7/etc/php-f'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007ff2c327f53f in do_lookup_x (new_hash=3286882123, old_hash=0x7fffd99d7ab8, ref=<value optimized out>, result=0x7fffd99d7aa0, scope=<value optimized out>, i=0, flags=1, skip=0x0,
    undef_map=0x30d6da0) at dl-lookup.c:232
232                           & map->l_gnu_bitmask_idxbits];
(gdb) bt
#0  0x00007ff2c327f53f in do_lookup_x (new_hash=3286882123, old_hash=0x7fffd99d7ab8, ref=<value optimized out>, result=0x7fffd99d7aa0, scope=<value optimized out>, i=0, flags=1, skip=0x0,
    undef_map=0x30d6da0) at dl-lookup.c:232
#1  0x00007ff2c327ff0a in _dl_lookup_symbol_x (undef_name=0x7ff2c13b0676 "_zend_hash_init", undef_map=0x30d6da0, ref=0x7fffd99d7b18, symbol_scope=0x30d70f8, version=0x0, type_class=1,
    flags=1, skip_map=0x0) at dl-lookup.c:747
#2  0x00007ff2c32840c0 in _dl_fixup (l=<value optimized out>, reloc_arg=<value optimized out>) at ../elf/dl-runtime.c:118
#3  0x00007ff2c328a8f5 in _dl_runtime_resolve () at ../sysdeps/x86_64/dl-trampoline.S:41
#4  0x00007ff2c13b937e in zend_accel_init_shm () at /usr/src/php-7.0.0RC6/ext/opcache/ZendAccelerator.c:2385
#5  0x00007ff2c13b9bbe in accel_startup (extension=0x30d73f0) at /usr/src/php-7.0.0RC6/ext/opcache/ZendAccelerator.c:2638
#6  0x000000000083c966 in zend_extension_startup (extension=0x30d73f0) at /usr/src/php-7.0.0RC6/Zend/zend_extensions.c:176
#7  0x0000000000817ce1 in zend_llist_apply_with_del (l=0x10975e0, func=0x83c93c <zend_extension_startup>) at /usr/src/php-7.0.0RC6/Zend/zend_llist.c:171
#8  0x000000000083c9d9 in zend_startup_extensions () at /usr/src/php-7.0.0RC6/Zend/zend_extensions.c:197
#9  0x0000000000799b17 in php_module_startup (sf=0x107c2c0, additional_modules=0x107c200, num_additional_modules=1) at /usr/src/php-7.0.0RC6/main/main.c:2197
#10 0x00000000009047d0 in php_cgi_startup (sapi_module=0x107c2c0) at /usr/src/php-7.0.0RC6/sapi/fpm/fpm/fpm_main.c:837
#11 0x0000000000906ea7 in main (argc=6, argv=0x7fffd99d83b8) at /usr/src/php-7.0.0RC6/sapi/fpm/fpm/fpm_main.c:1788
 [2015-10-30 07:46 UTC] laruence@php.net
looks like some building issue. make sure you rebuild the opcache then make install it to the right location.
 [2015-10-30 07:50 UTC] nguyentu dot me at outlook dot com
The extensions like gd.so, mbstring.so, mcrypt.so... is working fine except opcache.so.

All of them in /usr/local/php7/lib/php/extensions/debug-non-zts-xxxxxxx
 [2015-10-30 12:08 UTC] nguyentu dot me at outlook dot com
Hi,

I just build it on Ubuntu 12.04 and it worked fine, but it does not work on CentOS 6.
Screenshot: http://prntscr.com/8x0y54

Please help!
 [2015-10-30 17:30 UTC] kalle@php.net
-Status: Open +Status: Feedback
 [2015-10-30 17:30 UTC] kalle@php.net
Hi

Can you try to do a completely fresh build, as in rebuilding from scratch and clearing all temp files and make sure paths are clean?

The backtraces are rather strange, and like Xinchen mentions, this seems like a build issue. Especially the first (non debug bt) is rather odd, as it should not be able to fail at all, and then later in the debug build, it passes that point with no problem. The second bt tells me there is a symbol loading issue, which should not be possible as the zend_hash_init function and co, are already imported from an include in zend.h
 [2015-10-30 23:21 UTC] nguyentu dot me at outlook dot com
-Status: Feedback +Status: Open
 [2015-10-30 23:21 UTC] nguyentu dot me at outlook dot com
Hi,

I use the services of DigitalOcean" vs VULTR. I've rebuilt the VPS several times to test it again, but all failed.

If you want I'm very pleased to send you a VPS with SSH root account. Thank you!
 [2015-11-02 08:30 UTC] pei dot greet at qq dot com
I got the same error in CentOs6.5
------------------------
gdb /opt/php7/sbin/php-fpm /var/log/php-fpm.core.33381
GNU gdb (GDB) Red Hat Enterprise Linux (7.2-83.el6)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /opt/php7/sbin/php-fpm...done.
BFD: Warning: /var/log/php-fpm.core.33381 is truncated: expected core file size >= 6447104, found: 1130496.
[New Thread 33381]
Cannot access memory at address 0x33f0421168
Cannot access memory at address 0x33f0421168
Cannot access memory at address 0x33f0421168
Reading symbols from /lib64/ld-linux-x86-64.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/ld-linux-x86-64.so.2
Failed to read a valid object file image from memory.
Core was generated by `/opt/php7/sbin/php-fpm --daemonize --fpm-config /opt/php7/etc/php-fpm.conf --pi'.
Program terminated with signal 11, Segmentation fault.
#0  0x00000033f0729008 in ?? ()
Missing separate debuginfos, use: debuginfo-install glibc-2.12-1.149.el6_6.7.x86_64
---------------------------------
 [2015-11-02 08:53 UTC] pei dot greet at qq dot com
Reading symbols from /usr/lib64/libsmime3.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libsmime3.so
Reading symbols from /usr/lib64/libnss3.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libnss3.so
Reading symbols from /usr/lib64/libnssutil3.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libnssutil3.so
Reading symbols from /lib64/libplds4.so...(no debugging symbols found)...done.
Loaded symbols for /lib64/libplds4.so
Reading symbols from /lib64/libplc4.so...(no debugging symbols found)...done.
Loaded symbols for /lib64/libplc4.so
Reading symbols from /lib64/libnspr4.so...(no debugging symbols found)...done.
Loaded symbols for /lib64/libnspr4.so
Reading symbols from /usr/lib64/libssh2.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libssh2.so.1
Reading symbols from /lib64/liblber-2.4.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/liblber-2.4.so.2
more info with gdb
--------------------------------

Reading symbols from /usr/lib64/libsasl2.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libsasl2.so.2
Reading symbols from /lib64/libkrb5support.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib64/libkrb5support.so.0
Reading symbols from /lib64/libkeyutils.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/libkeyutils.so.1
Reading symbols from /lib64/libselinux.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/libselinux.so.1
Reading symbols from /opt/php7/lib/php/extensions/no-debug-non-zts-20151012/opcache.so...done.
Loaded symbols for /opt/php7/lib/php/extensions/no-debug-non-zts-20151012/opcache.so
Reading symbols from /opt/php7/lib/php/extensions/no-debug-non-zts-20151012/yaf.so...done.
Loaded symbols for /opt/php7/lib/php/extensions/no-debug-non-zts-20151012/yaf.so
Core was generated by `/opt/php7/sbin/php-fpm --daemonize --fpm-config /opt/php7/etc/php-fpm.conf --pi'.
Program terminated with signal 11, Segmentation fault.
#0  0x00000033f0729008 in __strcmp_sse42 () from /lib64/libc.so.6
Missing separate debuginfos, use: debuginfo-install cyrus-sasl-lib-2.1.23-15.el6_6.2.x86_64 freetype-2.3.11-15.el6_6.1.x86_64 glibc-2.12-1.149.el6_6.7.x86_64 keyutils-libs-1.4-5.el6.x86_64 krb5-libs-1.10.3-37.el6_6.x86_64 libcom_err-1.41.12-21.el6.x86_64 libcurl-7.19.7-40.el6_6.4.x86_64 libidn-1.18-2.el6.x86_64 libjpeg-turbo-1.2.1-3.el6_5.x86_64 libpng-1.2.49-1.el6_2.x86_64 libselinux-2.0.94-5.8.el6.x86_64 libssh2-1.4.2-1.el6.x86_64 libtool-ltdl-2.2.6-15.5.el6.x86_64 libxml2-2.7.6-17.el6_6.1.x86_64 nspr-4.10.0-1.el6.x86_64 nss-3.15.1-15.el6.x86_64 nss-softokn-freebl-3.14.3-22.el6_6.x86_64 nss-util-3.15.1-3.el6.x86_64 openldap-2.4.39-8.el6.x86_64 openssl-1.0.1e-30.el6.8.x86_64 zlib-1.2.3-29.el6.x86_64
(gdb) bt
#0  0x00000033f0729008 in __strcmp_sse42 () from /lib64/libc.so.6
#1  0x00007ffdba9422a9 in accel_find_sapi (extension=<value optimized out>)
    at /data/src/php-src-php-7.0.0RC6/ext/opcache/ZendAccelerator.c:2355
#2  accel_startup (extension=<value optimized out>) at /data/src/php-src-php-7.0.0RC6/ext/opcache/ZendAccelerator.c:2613
#3  0x0000000000814d41 in zend_extension_startup (extension=0x203a5f0) at /data/src/php-src-php-7.0.0RC6/Zend/zend_extensions.c:176
#4  0x00000000007fe6b3 in zend_llist_apply_with_del (l=0x11621a0, func=0x814d30 <zend_extension_startup>)
    at /data/src/php-src-php-7.0.0RC6/Zend/zend_llist.c:171
#5  0x0000000000814d27 in zend_startup_extensions () at /data/src/php-src-php-7.0.0RC6/Zend/zend_extensions.c:197
#6  0x00000000007adeda in php_module_startup (sf=<value optimized out>, additional_modules=<value optimized out>, 
    num_additional_modules=<value optimized out>) at /data/src/php-src-php-7.0.0RC6/main/main.c:2197
#7  0x00000000008a70d5 in php_cgi_startup (sapi_module=<value optimized out>)
    at /data/src/php-src-php-7.0.0RC6/sapi/fpm/fpm/fpm_main.c:837
#8  0x00000000008a794e in main (argc=6, argv=0x7fff549397c8) at /data/src/php-src-php-7.0.0RC6/sapi/fpm/fpm/fpm_main.c:1788
 [2015-11-02 10:11 UTC] nguyentu dot me at outlook dot com
try with the following os

CentOS 7 ok
Ubuntu 12.04 ok
FreeBSD ok

CentOS 6 fail
 [2015-11-30 01:26 UTC] apircalabu at gmail dot com
CentOS 6 64bit with RC8 installed.

php70-php-opcache-7.0.0-0.25.RC8.el6.remi.x86_64

Core was generated by `/opt/remi/php70/root/usr/bin/php -v'.
Program terminated with signal 11, Segmentation fault.
#0  zend_llist_del_element (l=0x9dc8e0, element=0x0, compare=0x7fcb85d40590 <accelerator_remove_cb>) at /usr/src/debug/php-7.0.0RC8/Zend/zend_llist.c:91
91	{
Missing separate debuginfos, use: debuginfo-install GeoIP-1.6.5-1.el6.x86_64 ImageMagick-last-libs-6.9.2.6-1.el6.remi.x86_64 aspell-0.60.6-12.el6.x86_64 audit-libs-2.3.7-5.el6.x86_64 bzip2-libs-1.0.5-7.el6_0.x86_64 cyrus-sasl-lib-2.1.23-15.el6_6.2.x86_64 db4-4.7.25-20.el6_7.x86_64 enchant-1.5.0-5.el6.x86_64 expat-2.0.1-11.el6_2.x86_64 fastlz-0.1.0-0.1.20070619svnrev12.el6.remi.x86_64 fftw-3.2.1-3.1.el6.x86_64 fontconfig-2.8.0-5.el6.x86_64 freetype-2.3.11-15.el6_6.1.x86_64 gd-last-2.1.1-2.el6.remi.x86_64 glib2-2.28.8-4.el6.x86_64 gmp-4.3.1-7.el6_2.2.x86_64 keyutils-libs-1.4-5.el6.x86_64 lcms2-2.3-2.el6.x86_64 libICE-1.0.6-1.el6.x86_64 libSM-1.2.1-2.el6.x86_64 libX11-1.6.0-6.el6.x86_64 libXau-1.0.6-4.el6.x86_64 libXext-1.3.2-2.1.el6.x86_64 libXpm-3.5.10-2.el6.x86_64 libXt-1.1.4-6.1.el6.x86_64 libc-client-2007e-11.el6.x86_64 libcurl-7.19.7-46.el6.x86_64 libedit-2.11-4.20080712cvs.1.el6.x86_64 libgcrypt-1.4.5-11.el6_4.x86_64 libgpg-error-1.7-4.el6.x86_64 libicu-last-50.1.2-11.el6.remi.x86_64 libidn-1.18-2.el6.x86_64 libjpeg-turbo-1.2.1-3.el6_5.x86_64 libmcrypt-2.5.8-9.el6.x86_64 libmemcached-1.0.17-1.rhel6.x86_64 libpng-1.2.49-1.el6_2.x86_64 libselinux-2.0.94-5.8.el6.x86_64 libssh2-1.4.2-1.el6_6.1.x86_64 libtidy-0.99.0-19.20070615.1.el6.x86_64 libtiff-3.9.4-10.el6_5.x86_64 libtool-ltdl-2.2.6-15.5.el6.x86_64 libuuid-2.17.2-12.18.el6.x86_64 libvpx-1.3.0-5.el6_5.x86_64 libxcb-1.9.1-3.el6.x86_64 libxslt-1.1.26-2.el6_3.1.x86_64 libzip-last-1.0.1-1.el6.remi.x86_64 net-snmp-libs-5.5-54.el6_7.1.x86_64 nspr-4.10.8-2.el6_7.x86_64 nss-3.19.1-5.el6_7.x86_64 nss-util-3.19.1-2.el6_7.x86_64 openldap-2.4.40-7.el6_7.x86_64 pam-1.1.1-20.el6_7.1.x86_64 php70-php-pecl-apcu-5.1.0-1.el6.remi.x86_64 php70-php-pecl-geoip-1.1.0-9.el6.remi.x86_64 php70-php-pecl-imagick-3.3.0-0.6.20150930gitfccdde3.el6.remi.x86_64 php70-php-pecl-memcached-2.2.0-11.20150628git3c79a97.el6.remi.x86_64 php70-php-pecl-msgpack-2.0.0-1.el6.remi.x86_64 php70-php-pecl-uploadprogress-1.0.3.1-11.el6.remi.x86_64 php70-php-pecl-uuid-1.0.4-6.el6.remi.x86_64 php70-php-pecl-zip-1.13.1-3.el6.remi.x86_64 postgresql93-libs-9.3.10-1PGDG.rhel6.x86_64 sqlite-3.6.20-1.el6_7.2.x86_64 tokyocabinet-1.4.33-6.el6.x86_64 unixODBC-2.2.14-14.el6.x86_64
(gdb) bt
#0  zend_llist_del_element (l=0x9dc8e0, element=0x0, compare=0x7fcb85d40590 <accelerator_remove_cb>) at /usr/src/debug/php-7.0.0RC8/Zend/zend_llist.c:91
#1  0x00007fcb85d425b1 in zps_startup_failure (extension=<value optimized out>) at /usr/src/debug/php-7.0.0RC8/ext/opcache/ZendAccelerator.c:2336
#2  accel_startup (extension=<value optimized out>) at /usr/src/debug/php-7.0.0RC8/ext/opcache/ZendAccelerator.c:2621
#3  0x00000000005edbb1 in zend_extension_startup (extension=0x28a0190) at /usr/src/debug/php-7.0.0RC8/Zend/zend_extensions.c:176
#4  0x00000000005d7123 in zend_llist_apply_with_del (l=0x9dc8e0, func=0x5edba0 <zend_extension_startup>) at /usr/src/debug/php-7.0.0RC8/Zend/zend_llist.c:171
#5  0x00000000005edb97 in zend_startup_extensions () at /usr/src/debug/php-7.0.0RC8/Zend/zend_extensions.c:197
#6  0x0000000000585815 in php_module_startup (sf=<value optimized out>, additional_modules=<value optimized out>, num_additional_modules=<value optimized out>) at /usr/src/debug/php-7.0.0RC8/main/main.c:2197
#7  0x00000000006761bd in php_cli_startup (sapi_module=<value optimized out>) at /usr/src/debug/php-7.0.0RC8/sapi/cli/php_cli.c:423
#8  0x00000000006778e1 in main (argc=2, argv=0x28589e0) at /usr/src/debug/php-7.0.0RC8/sapi/cli/php_cli.c:1325
 [2015-11-30 02:20 UTC] nguyentu dot me at outlook dot com
This bug has been fixed in RC8. Thank all!
 [2015-11-30 02:53 UTC] laruence@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: laruence
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 17:05:44 2022 UTC