php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #70673 Wrong Parameter Info for SplFileInfo::__construct()
Submitted: 2015-10-08 18:21 UTC Modified: 2015-10-12 09:41 UTC
From: lukasl dot com at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 5.5.30 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lukasl dot com at gmail dot com
New email:
PHP Version: OS:

 

 [2015-10-08 18:21 UTC] lukasl dot com at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/splfileinfo.construct
---

Documentation says:

public SplFileInfo::__construct ( string $file_name )


Expected result:
----------------
Documentation should say:

public SplFileInfo::__construct ($filename, $open_mode = "r", $use_include_path = false, $context = null)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-09 18:46 UTC] salathe@php.net
-Status: Open +Status: Not a bug
 [2015-10-09 18:46 UTC] salathe@php.net
You are confusing SplFileInfo with SplFileObject.
 [2015-10-12 09:41 UTC] lukasl dot com at gmail dot com
Yes, you're right. Sorry about that.
I clicked on the __construct() link in the /* Inherited methods */ section (didn't notice the real __construct() link under "Table of Contents"

This is the correct page for it and I see it's documented correctly.

http://php.net/manual/en/splfileobject.construct.php

Thanks for checking into this. My bad.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 07:01:24 2020 UTC