php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70603 Unicode version of IntlChar is old
Submitted: 2015-09-29 19:44 UTC Modified: 2015-09-30 09:24 UTC
From: fsb at thefsb dot org Assigned:
Status: Not a bug Package: intl (PECL)
PHP Version: 7.0.0RC3 OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fsb at thefsb dot org
New email:
PHP Version: OS:

 

 [2015-09-29 19:44 UTC] fsb at thefsb dot org
Description:
------------
Unicode version for IntlChar is 7.0.0.

Since IntlChar is new in PHP 7.0, it would be nice if it had an up to date Unicode version when PHP 7.0 get's to full release.

Test script:
---------------
\IntlChar::getUnicodeVersion()

Expected result:
----------------
[8,0,0,0]

Actual result:
--------------
[7,0,0,0]

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-09-30 09:24 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2015-09-30 09:24 UTC] ab@php.net
ext/intl doesn't implement Unicode itself, but is based on ICU. Unicode 8 is implemented in ICU 56 which is currently in the RC state. Later, when ICU 56 is released, just be sure you link PHP with ICU56 and above.

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Apr 06 01:01:27 2020 UTC