php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #70597 Missing info about json_decode bc changes
Submitted: 2015-09-28 09:59 UTC Modified: 2017-01-28 17:33 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: thephilosoft at gmail dot com Assigned: cmb (profile)
Status: Closed Package: JSON related
PHP Version: 7.0.0 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: thephilosoft at gmail dot com
New email:
PHP Version: OS:

 

 [2015-09-28 09:59 UTC] thephilosoft at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/migration70.incompatible
---


Missing this part https://github.com/php/php-src/commit/9d037d574cc359405c7a818c2235644633705999


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-21 16:47 UTC] jhdxr@php.net
could you give some test script?

I have tested (https://3v4l.org/M2fU2)
> json_decode(null)

and there is no bc change.
 [2015-10-24 20:29 UTC] thephilosoft at gmail dot com
yeah. of course, sorry for that unclear report (

here you go https://3v4l.org/VSIXH
 [2015-12-07 16:58 UTC] joe at joe dot codes
I find this is still an issue with the officially released of PHP 7, is it intentional? If so, it should be added to the documentation.

https://3v4l.org/UZJNC
 [2015-12-07 17:04 UTC] salathe@php.net
-PHP Version: 7.0.0RC3 +PHP Version: 7.0.0
 [2015-12-07 17:04 UTC] salathe@php.net
This is still a TODO item and this bug report will get updated when it is fixed.

For reference, here is the bug report that introduced the different behaviour: http://php.net/68938
 [2017-01-28 17:33 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=341796
Log: Fix #70597: Missing info about json_decode bc changes
 [2017-01-28 17:33 UTC] cmb@php.net
-Status: Open +Status: Closed -Package: Documentation problem +Package: JSON related -Assigned To: +Assigned To: cmb
 [2017-01-28 17:33 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2020-02-07 06:06 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=d53f9eda5d0d31042e01da2aca6ec98c08ce3f56
Log: Fix #70597: Missing info about json_decode bc changes
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 13:01:23 2020 UTC