php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70578 Could not compile memcache with php-7.0-RC3
Submitted: 2015-09-25 08:48 UTC Modified: 2015-10-24 04:50 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: aurelien dot bras at gmail dot com Assigned:
Status: Duplicate Package: Compile Failure
PHP Version: 7.0.0RC3 OS: Debian Jessie (8.0)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aurelien dot bras at gmail dot com
New email:
PHP Version: OS:

 

 [2015-09-25 08:48 UTC] aurelien dot bras at gmail dot com
Description:
------------
When trying to static compile memcache in php-7.0.0RC3, I got a fatal error while compiling.



Test script:
---------------
mv memcache-3.0.8 php-7.0.0RC3/ext/memcache
cd php-7.0.0RC3
mv configure configure-old
./buildconf --force
./configure \
        --prefix=/usr/php56 \
        --with-pear=/usr/php56/pear \
	--with-config-file-path=/etc/php56/fpm \
	--with-config-file-scan-dir=/etc/php56/fpm/conf.d \
        --disable-ipv6 \
        --disable-posix \
        --enable-session \
        --enable-memcache \
        --without-sqlite3 \
        --with-pcre-regex \
        --with-openssl \
        --with-zlib \
        --with-gd \
        --with-jpeg-dir \
        --with-png-dir \
        --with-zlib-dir \
        --with-freetype-dir \
        --with-t1lib \
        --enable-gd-native-ttf \
        --with-gettext \
        --with-iconv \
        --with-iconv-dir \
        --with-mysql \
        --with-mysqli \
        --enable-pdo \
        --without-pdo-sqlite \
        --with-pdo-mysql \
        --enable-simplexml \
        --enable-xml \
        --enable-dom \
        --with-xsl \
        --with-tidy \
        --enable-soap \
        --enable-ftp \
        --enable-exif \
        --enable-mbstring \
        --enable-zip \
        --with-curl \
        --enable-calendar \
        --with-mcrypt \
        --enable-bcmath \
	--enable-gd-native-ttf \
        --enable-intl \
	--with-fpm-systemd \
	--enable-fpm
make

Expected result:
----------------
Compilation working.

Actual result:
--------------
/bin/bash /usr/local/src/php-7.0.0RC3/libtool --silent --preserve-dup-deps --mode=compile cc -I/usr/local/src/php-7.0.0RC3 -Iext/memcache/ -I/usr/local/src/php-7.0.0RC3/ext/memcache/ -DPHP_ATOM_INC -I/usr/local/src/php-7.0.0RC3/include -I/usr/local/src/php-7.0.0RC3/main -I/usr/local/src/php-7.0.0RC3 -I/usr/local/src/php-7.0.0RC3/ext/date/lib -I/usr/include/libxml2 -I/usr/include/freetype2 -I/usr/local/src/php-7.0.0RC3/ext/mbstring/oniguruma -I/usr/local/src/php-7.0.0RC3/ext/mbstring/libmbfl -I/usr/local/src/php-7.0.0RC3/ext/mbstring/libmbfl/mbfl -I/usr/include/tidy -I/usr/local/src/php-7.0.0RC3/ext/zip/lib -I/usr/local/src/php-7.0.0RC3/TSRM -I/usr/local/src/php-7.0.0RC3/Zend    -I/usr/include -g -O2 -fvisibility=hidden   -c /usr/local/src/php-7.0.0RC3/ext/memcache/memcache.c -o ext/memcache/memcache.lo 
In file included from /usr/local/src/php-7.0.0RC3/ext/memcache/php_memcache.h:34:0,
                 from /usr/local/src/php-7.0.0RC3/ext/memcache/memcache.c:30:
/usr/local/src/php-7.0.0RC3/ext/memcache/memcache_pool.h:45:47: fatal error: ext/standard/php_smart_str_public.h: No such file or directory
 #include "ext/standard/php_smart_str_public.h"
                                               ^
compilation terminated.
Makefile:2004: recipe for target 'ext/memcache/memcache.lo' failed
make: *** [ext/memcache/memcache.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-24 04:50 UTC] kalle@php.net
Hi, I'm closing this in favour of bug #70751. Long story short, basically pecl/memcache have not yet been ported to run under php7 and haven't had a release since 2012
 [2015-10-24 04:50 UTC] kalle@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Mar 22 20:01:27 2019 UTC