php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70563 strtotime accepts spaces, dots and comma's as valid
Submitted: 2015-09-23 14:03 UTC Modified: 2021-04-05 16:21 UTC
From: daftwally at gmail dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: daftwally at gmail dot com
New email:
PHP Version: OS:

 

 [2015-09-23 14:03 UTC] daftwally at gmail dot com
Description:
------------
the strtotime() function accepts a string with one or more spaces (' '), one or more dots  ('.') or one or more comma's (',') or a combination of these with no other valid date/time information as acceptable and returns a timestamp (now) instead of the expected FALSE.

Here is the output on a bunch of different PHP versions -> https://3v4l.org/kSH46

Test script:
---------------
<?php
	var_dump(strtotime(" "));
	var_dump(strtotime(","));
	var_dump(strtotime("."));
	var_dump(strtotime(". .. .. .. .... .. . .. ."));
	var_dump(strtotime(". .. .. .. ..,,,.. .. . .. ."));
	var_dump(strtotime("bogus"));

Expected result:
----------------
boolean false
boolean false
boolean false
boolean false
boolean false
boolean false

Actual result:
--------------
int 1443016200
int 1443016200
int 1443016200
int 1443016200
int 1443016200
boolean false

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-03-29 18:13 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2021-04-05 16:21 UTC] derick@php.net
-Status: Verified +Status: Not a bug
 [2021-04-05 16:21 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 06:01:29 2024 UTC