php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70559 subtraction float numbers bug
Submitted: 2015-09-23 11:11 UTC Modified: 2015-09-23 12:24 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: jakub dot trzcinski at valueadd dot pl Assigned:
Status: Not a bug Package: Math related
PHP Version: 5.6.13 OS: Windows And Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jakub dot trzcinski at valueadd dot pl
New email:
PHP Version: OS:

 

 [2015-09-23 11:11 UTC] jakub dot trzcinski at valueadd dot pl
Description:
------------
it's doesnt matter which is type(int/float) of seccond value, its always bad result.

Test script:
---------------
$a = 217.80;
$b = 217;
echo $a - $b;

------------------------

$a = 217.80;
$b = 217.00;
echo $a - $b;

Expected result:
----------------
0.8

Actual result:
--------------
0.80000000000001

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-09-23 12:24 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2015-09-23 12:24 UTC] ab@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Floating point numbers have limited precision. Often it's like 7 significant places on 32-bit and 15 on 64-bit. It is platform dependent. What you experience is therefore expected behavior.

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 28 22:01:26 2020 UTC