php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70536 Webserver crashes when posix_kill PID is null
Submitted: 2015-09-20 15:13 UTC Modified: 2015-09-20 16:38 UTC
From: roberto-1995 at live dot it Assigned:
Status: Not a bug Package: POSIX related
PHP Version: 5.4.45 OS: Debian GNU/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roberto-1995 at live dot it
New email:
PHP Version: OS:

 

 [2015-09-20 15:13 UTC] roberto-1995 at live dot it
Description:
------------
Lighttpd web server: getting a pid from a database. there was no row so I was getting null. when calling posix_kill(SIGUSR1, $pid) the webserver crashed.



Test script:
---------------
<?php

$pid = NULL;

posix_kill(SIGUSR1, $pid);

?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-09-20 16:38 UTC] laruence@php.net
If pid equals 0, then sig is sent to every process in the process group of the calling process.
 [2015-09-20 16:38 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 [2015-09-20 16:38 UTC] laruence@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 03:01:28 2024 UTC