php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70370 Bundled libtool.m4 doesn't handle FreeBSD 10 when building extensions
Submitted: 2015-08-27 18:38 UTC Modified: 2015-08-27 23:02 UTC
From: aharvey@php.net Assigned: aharvey (profile)
Status: Closed Package: *Compile Issues
PHP Version: Irrelevant OS: FreeBSD 10
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: aharvey@php.net
New email:
PHP Version: OS:

 

 [2015-08-27 18:38 UTC] aharvey@php.net
Description:
------------
Our libtool.m4 incorrectly detects FreeBSD 10 as FreeBSD 1 when building extensions, thereby causing issues with the built extension being (at best) misnamed. You can see the (obvious) root cause at https://github.com/php/php-src/blob/PHP-5.4/build/libtool.m4#L1542 (it's the same up to and including master, but the exact line number changes slightly).

In the longer term (PHP 7.1?) we should probably upgrade the entire file to something more recent, but for now, I'm going to look into applying a similar fix to the one Ferenc landed for bug #67091 to the offending line.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-08-27 18:38 UTC] aharvey@php.net
-Assigned To: +Assigned To: aharvey
 [2015-08-27 23:02 UTC] aharvey@php.net
-Status: Assigned +Status: Closed
 [2015-08-27 23:02 UTC] aharvey@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 24 03:01:25 2020 UTC