php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70347 Bogus/wrong error message "please don't spam our bug tracker" message
Submitted: 2015-08-24 21:50 UTC Modified: 2015-08-24 21:54 UTC
From: teo8976 at gmail dot com Assigned:
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: teo8976 at gmail dot com
New email:
PHP Version: OS:

Further comment on this bug is unnecessary.

 

 [2015-08-24 21:50 UTC] teo8976 at gmail dot com
Description:
------------
I am forced to open a duplicate report, because some idiot not only closed the original bug report as "not a bug" without giving an explanation, but unnecessarily locked it to comments, so I cannot comment there asking for clarifications or for reopening.

https://bugs.php.net/bug.php?id=70336
Closed as "not a bug" with this comment:
" You have to much [sic] time on your hands."

What is that supposed to mean?!?


So don't complain if you get an unnecessary duplicate, it's not my fault.
Here it goes again

I was trying to comment on a bug and I used the expression "don't give a ****", with the actual "f word" instead of the ****.

A part from the questionable use of unelegant language, my comment was completely legitimate.

As a result, when trying to post the comment I kept getting the message "Please don't SPAM our website" (or something like that).

At first I thought it was the wrong captcha (my fault, the error message for that is different and clear enough), but then I had a hard time figuring out what the problem was.

I thought I might be being blocked because of "too many" comments from the same email address, so I tried another. Then I tried another browser.

The bottom line is that I WASTED A LOT OF TIME just because of a poorly phrased error message. The error message should say "We don't allow the word XXXX", or at least "Please don't use profanity" or the like.

And don't tell me that would help spammers to work around the antispam filter, because obviously spam comes from spambots, not human beings.

This reminds me of https://bugs.php.net/bug.php?id=64929
Seriously, this is the only bug tracker where I haver seen this kind of stuff.


Suggestion: if users had to register and login in order to file bugs (with email verification and captcha whenever necessary, real captcha I mean), as happens in EVERY OTHER bug tracker I've ever seen, you wouldn't need stupid word-based filters with such a high rate of false positive (nor would you have to trade it off with the rate of actual spam blocking).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-08-24 21:54 UTC] kalle@php.net
-Status: Open +Status: Not a bug -Block user comment: No +Block user comment: Yes
 [2015-08-24 21:54 UTC] kalle@php.net
Yeah I think we had enough with this language, you are welcome to come with a proper [formal] suggestion on the webmaster mailing list instead.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 29 03:03:49 2022 UTC