php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #70297 Unable to find PHP Extensions
Submitted: 2015-08-19 02:06 UTC Modified: 2015-08-19 05:29 UTC
From: bpswem at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 5.4.44 OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: bpswem at gmail dot com
New email:
PHP Version: OS:

 

 [2015-08-19 02:06 UTC] bpswem at gmail dot com
Description:
------------
Docementation lists location where to place the dll file for an extension and how to load the extension in the php.ini file, however there eis no referance, hint, guide or anything with reguard as to where to find the dlls in the first place. The help page is uterly usless for lack of any usable referances. No forums, no IRc channels, nothing which can be used to find any usable information. The only direct information is toward this bug reporting system so her eis where I am posting since this is the ONLY defined place provided for obtaining support.

Again using PHP under IIS on a Windows machine so absolutely none of the millions of support pages referance methods for installing under a linux using command line (typically using apt-get install) will work.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-08-19 02:13 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2015-08-19 02:13 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Have you looked in the ext/ directory?
 [2015-08-19 03:19 UTC] bpswem at gmail dot com
I have looked in the ext/ directory, the dlls for the extensions I need are not there.

I aldo did look at http://www.php.net/support.php as this was the first place I looked to find help. It was via http://www.php.net/support.php that I found myself here as the only viable location to post my question and to seek assistance.

A forum system would be usefull for situations like this.
 [2015-08-19 05:29 UTC] requinix@php.net
Thing is, this is not a place for assistance. This is a bug reporting system. There are mailing lists (official PHP lists and not), user groups (which may have their own mailing lists), countless forums... Those are more appropriate places to find help than here.

If the extension is hosted on pear.php.net then they *might* have pre-built Windows binaries. If not then you'll just have to keep searching because the best singular place to find PHP extensions is google.com. Or you can build it from source yourself.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Nov 27 18:01:25 2020 UTC