php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70212 sapi/cli/php: object requires TLS, but TLS failed to initialize
Submitted: 2015-08-08 08:30 UTC Modified: -
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: truniger at bluewin dot ch Assigned:
Status: Open Package: Compile Failure
PHP Version: 5.5.28 OS: Solaris
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: truniger at bluewin dot ch
New email:
PHP Version: OS:

 

 [2015-08-08 08:30 UTC] truniger at bluewin dot ch
Description:
------------
compiling 5.5.28 and 5.6.12 fails resulting in this error line:
sapi/cli/php: object requires TLS, but TLS failed to initialize

this happens with the exact same environment and configure options as with 5.5.27 and 5.6.11 where there was no such problem.

I assume a common change in both 5.5 and 5.6 tree causes my problem. But I have no clue what to look for. 

I tried with reverting patch for ext/openssl/openssl.c but this doesn't make a difference.

I'm using some older gcc and GNU ld on Solaris. I guess that's a little exotic but if it worked for 5.5.27 which is in production it should work also for 5.5.28. Please help so I can use the security fixes.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-08-15 12:33 UTC] truniger at bluewin dot ch
The problem is caused by the patch of #70002 to main/php_open_temporary_file.c. Reverting this patch removes the problem for both 5.5.28 and 5.6.12.

Compilation of the source does not throw an error but all the binaries are broken. The resulting error message "object requires TLS, but TLS failed to initialize" is thrown when running the broken php binary to create phar. I guess the problem is not really related to TLS.

So I guess patch of #70002 needs an update for Solaris but I have no clue about it.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Sep 21 17:01:27 2019 UTC