php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70151 soap/php_encoding.c uses wrong type to call unset_property
Submitted: 2015-07-27 08:14 UTC Modified: 2015-08-03 06:37 UTC
From: stas@php.net Assigned: stas (profile)
Status: Not a bug Package: SOAP related
PHP Version: 5.6.11 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stas@php.net
New email:
PHP Version: OS:

 

 [2015-07-27 08:14 UTC] stas@php.net
Description:
------------
soap/php_encoding.c has this code in unset_zval_property():

                zval member;
                zend_class_entry *old_scope;

                INIT_PZVAL(&member);
                ZVAL_STRING(&member, name, 0);
                old_scope = EG(scope);
                EG(scope) = Z_OBJCE_P(object);
                Z_OBJ_HT_P(object)->unset_property(object, &member, 0 TSRMLS_CC);

However, since 5.4 the signature of unset_property is:

void (*zend_object_unset_property_t)(zval *object, zval *member, const struct _zend_literal *key TSRMLS_DC);

So this code needs to be updated.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-07-27 08:15 UTC] stas@php.net
-Assigned To: +Assigned To: dmitry
 [2015-07-27 08:15 UTC] stas@php.net
-Assigned To: dmitry +Assigned To: stas
 [2015-07-27 08:16 UTC] stas@php.net
-Status: Assigned +Status: Not a bug
 [2015-07-27 08:16 UTC] stas@php.net
Oops, no, the code is correct, my mistake.
 [2015-08-03 06:37 UTC] dmitry@php.net
0 (zero) may be changed to NULL, but this won't affect the resulting code.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 28 04:03:33 2021 UTC