php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7011 httpd.h not found at correct location
Submitted: 2000-10-04 06:12 UTC Modified: 2001-08-28 12:29 UTC
From: jjensen at bak dot rr dot com Assigned:
Status: Not a bug Package: Installation problem
PHP Version: Earlier? Upgrade first! OS: Redhat 6.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jjensen at bak dot rr dot com
New email:
PHP Version: OS:

 

 [2000-10-04 06:12 UTC] jjensen at bak dot rr dot com
I have been trying to install php3 on Redhat 6.1, because my IP (co-location) warned me to stay away from php4 with my Linux version. Too many problems, and I am too inexperienced to want them.

I keep getting error messages. The instructions said use:
	./configure --with-mysql --with-apache_1.3.x --enable-track-vars

That is what I did, but this didn't give the correct location for mysql, so:
	./configure --with-mysql=/usr/local/mysql --with-apache_1.3.9 --enable-track-vars	

That was an invalid location for apache, so I did a "locate apache"  and httpd -v to get the right version number:
	./configure --with-mysql=/usr/local/mysql --with-apache_1.3.9 --enable-track-vars

No, it wanted an address:
	./configure --with-mysql=/usr/local/mysql --with-apache=/usr/lib/apache_1.3.9 --enable-track-vars

It didn't like that location, saying it needed httpd.h, so:
	./configure --with-mysql=/usr/local/mysql --with-apache=/usr/include/apache/ --enable-track-vars
	./configure --with-mysql=/usr/local/mysql --with-apache=/usr/include/apache/ --enable-track-vars

"Invalid Apache directory - unable to find httpd.h /under user/include/apache"

That is the only place it is turning up. Why can't INSTALL find it there? I even name the file:
	./configure --with-mysql=/usr/local/mysql --with-apache=/usr/include/apache/httpd.h --enable-track-vars

Still doesn't work, but when I do a locate, it IS there.

I'm stuck guys. Your instructions DON'T WORK. Any ideas?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-28 12:29 UTC] hholzgra@php.net
--with-apache needs the apache _source_ directory as argument

definetly a question for php-general or php-install 
mailing list and not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 16:03:35 2021 UTC