php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70071 'makes pointer from integer without a cast' in several function calls
Submitted: 2015-07-14 12:34 UTC Modified: 2016-03-28 08:10 UTC
From: pgajdos at suse dot cz Assigned: mariuz (profile)
Status: Closed Package: InterBase related
PHP Version: 7.0.0beta1 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
9 - 3 = ?
Subscribe to this entry?

 
 [2015-07-14 12:34 UTC] pgajdos at suse dot cz
Description:
------------
'makes pointer from integer without a cast' warning appears several times in interbase code:

[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/interbase.c:1239:62: warning: passing argument 1 of 'zend_fetch_resource2_ex' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/interbase.c:1333:54: warning: passing argument 1 of 'zend_fetch_resource2_ex' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/interbase.c:1442:68: warning: passing argument 1 of 'zend_fetch_resource2' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_query.c:1144:56: warning: passing argument 1 of 'zend_fetch_resource2_ex' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_query.c:1213:54: warning: passing argument 1 of 'zend_fetch_resource2_ex' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_query.c:1743:54: warning: passing argument 1 of 'zend_fetch_resource2_ex' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_events.c:105:40: warning: passing argument 1 of 'isc_event_block' from incompatible pointer type [-Wincompatible-pointer-types]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_events.c:118:19: warning: passing argument 1 of 'isc_event_counts' from incompatible pointer type [-Wincompatible-pointer-types]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_events.c:155:59: warning: passing argument 1 of 'zend_fetch_resource2_ex' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_events.c:178:19: warning: passing argument 1 of 'isc_event_counts' from incompatible pointer type [-Wincompatible-pointer-types]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_events.c:224:21: warning: passing argument 1 of 'isc_event_counts' from incompatible pointer type [-Wincompatible-pointer-types]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_events.c:313:59: warning: passing argument 1 of 'zend_fetch_resource2_ex' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_blobs.c:216:68: warning: passing argument 1 of 'zend_fetch_resource2' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_blobs.c:261:68: warning: passing argument 1 of 'zend_fetch_resource2' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_blobs.c:424:68: warning: passing argument 1 of 'zend_fetch_resource2' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_blobs.c:501:68: warning: passing argument 1 of 'zend_fetch_resource2' makes pointer from integer without a cast [-Wint-conversion]
[  167s] /home/abuild/rpmbuild/BUILD/php-7.0.0beta1/ext/interbase/ibase_blobs.c:554:68: warning: passing argument 1 of 'zend_fetch_resource2' makes pointer from integer without a cast [-Wint-conversion]

See https://build.opensuse.org/package/live_build_log/devel:languages:php:php7/php7/openSUSE_Tumbleweed/x86_64 for details.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-07-14 13:32 UTC] ab@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: mariuz
 [2015-07-14 13:32 UTC] ab@php.net
Hi Marius,

please take a look.

Thanks.
 [2016-03-28 08:10 UTC] krakjoe@php.net
-Status: Assigned +Status: Closed
 [2016-03-28 08:10 UTC] krakjoe@php.net
This was fixed sometime after the beta releases, and is not reproducible today.

It could not have been caused by interbase; That symbol is defined in a file that should have been included by zend api headers (which every extension must include), it never required explicit inclusion.

Closing the bug.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jul 03 08:04:07 2022 UTC