php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #69962 php://temp / php://memory don't support stat()
Submitted: 2015-06-29 15:59 UTC Modified: 2020-12-18 12:40 UTC
Votes:13
Avg. Score:3.9 ± 0.8
Reproduced:13 of 13 (100.0%)
Same Version:11 (84.6%)
Same OS:10 (76.9%)
From: phansys at gmail dot com Assigned: cmb (profile)
Status: Closed Package: Streams related
PHP Version: Irrelevant OS: Unix/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: phansys at gmail dot com
New email:
PHP Version: OS:

 

 [2015-06-29 15:59 UTC] phansys at gmail dot com
Description:
------------
Streams php://temp and php://memory don't support stat(), while documentation says it should be supported: http://php.net/manual/en/wrappers.php.php#refsect1-wrappers.php-options


Test script:
---------------
$ php -r "var_dump(stat('php://temp'));" 
PHP Warning:  stat(): stat failed for php://temp in Command line code on line 1
bool(false)

$ php -r "var_dump(stat('php://memory'));"
PHP Warning:  stat(): stat failed for php://memory in Command line code on line 1
bool(false)


Actual result:
--------------
PHP Warning:  stat(): stat failed for php://memory in Command line code on line 1
bool(false)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-11-30 18:25 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2016-11-30 18:25 UTC] cmb@php.net
Confirmed: <https://3v4l.org/OmDis>. I'm not sure, however, if this is rather a documentation bug.
 [2018-08-27 18:55 UTC] vhu at iki dot fi
I agree this looks like a documentation issue. Both php://temp and php://memory support fstat() but no stat().

See https://3v4l.org/6TpPg
 [2020-12-18 12:40 UTC] cmb@php.net
-Type: Bug +Type: Documentation Problem -Assigned To: +Assigned To: cmb
 [2020-12-18 12:40 UTC] cmb@php.net
Changing to doc bug.
 [2020-12-18 12:44 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=352123
Log: Fix #69962: php://temp / php://memory don't support stat()
 [2020-12-18 12:44 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=8ebad33b9c1eba4e84bfc95d4de544801742d4b1
Log: Fix #69962: php://temp / php://memory don't support stat()
 [2020-12-18 12:44 UTC] phpdocbot@php.net
-Status: Verified +Status: Closed
 [2020-12-18 23:51 UTC] mumumu@php.net
Automatic comment from SVN on behalf of mumumu
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=352125
Log: Fix #69962: php://temp / php://memory don't support stat()
 [2020-12-18 23:55 UTC] phpdocbot@php.net
Automatic comment on behalf of mumumu
Revision: http://git.php.net/?p=doc/ja.git;a=commit;h=5efc0038454a85f9d798739f8868f0976484abc6
Log: Fix #69962: php://temp / php://memory don't support stat()
 [2020-12-30 11:58 UTC] nikic@php.net
Automatic comment on behalf of mumumu
Revision: http://git.php.net/?p=doc/ja.git;a=commit;h=4739c91c8201eb9bddc9ec89db87062c2c65b6e9
Log: Fix #69962: php://temp / php://memory don't support stat()
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Feb 24 21:01:24 2021 UTC