|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #69946 Beta packages marked as 'stable'
Submitted: 2015-06-26 18:29 UTC Modified: 2016-11-09 10:48 UTC
Avg. Score:4.2 ± 1.5
Reproduced:6 of 6 (100.0%)
Same Version:2 (33.3%)
Same OS:1 (16.7%)
From: mstyne at ubersmith dot com Assigned: koubel (profile)
Status: Closed Package: rrd (PECL)
PHP Version: Irrelevant OS: Debian 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: mstyne at ubersmith dot com
New email:
PHP Version: OS:


 [2015-06-26 18:29 UTC] mstyne at ubersmith dot com
Attempting to install 'stable' rrd package like so:

pecl -d preferred_state=stable install -a rrd 

results in the following:

pecl/rrd requires PHP (version >= 7.0.0), installed version is 5.4.41-0+deb7u1

I'm guessing that this is just an oversight on the labeling of the packages.

Expected result:
Version 1.1.3 should be provided as the stable release.

Actual result:
2.0.0Beta2 is provided, with a requirement of

PHP Version: PHP 7.0.0 or newer

This fails on the majority of (all?) operating systems.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2016-11-09 10:45 UTC]
Sorry for later response.

Package has now 2 stable versions 2.x for PHP 7 and 1.x for PHP 5. I think it's correct to have more stable versions. There are many exts with more than one stable versions.
 [2016-11-09 10:48 UTC]
-Status: Open +Status: Closed -Assigned To: +Assigned To: koubel
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 28 05:03:38 2021 UTC