php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #69932 PHP Changelog should specifically state ZendOpcache version supported
Submitted: 2015-06-25 13:35 UTC Modified: 2019-01-25 16:06 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:2 (66.7%)
From: david at davidfavor dot com Assigned:
Status: Wont fix Package: Documentation problem
PHP Version: 5.6.10 OS: Ubuntu 15.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: david at davidfavor dot com
New email:
PHP Version: OS:

 

 [2015-06-25 13:35 UTC] david at davidfavor dot com
Description:
------------
Trying to figure out the maximum version of ZendOpcache supported on each version of PHP is difficult.

For example, https://pecl.php.net/package/ZendOpcache shows...

7.0.5 stable
7.0.4 stable

PHP 5.6.4 (Ubuntu) shows 7.0.4-dev so this seems to indicate running pecl install will install 7.0.4-stable which is not the case.

# pecl install zendopcache
pecl/zendopcache requires PHP (version >= 5.2.0, version <= 5.5.0), installed version is 5.6.4-4ubuntu6
No valid packages found
install failed

This message gives no useful information + trying to install latest produces an even worse message...

# pecl install -f zendopcache-7.0.5
/tmp/pear/temp/zendopcache/ZendAccelerator.c:39:35: fatal error: TSRM/tsrm_virtual_cwd.h: No such file or directory
 #include "TSRM/tsrm_virtual_cwd.h"

After reading many bug reports it appears...

PHP-5.6.x includes zendopcache-7.0.4-beta

PHP-7x will include zendopcache-7.0.5

And this is just a guess, as this is documented no where easily found.

Please add a simple line to each PHP changelog saying the exact version of opcache which is included/supported.

Thanks.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-25 13:46 UTC] david at davidfavor dot com
Also https://pecl.php.net/package/ZendOpcache contains an error.

Release 7.0.5 supports Version: PHP 5.2.0 or newer - false, will not compile on 5.6.x any version.

Release 7.0.4 supports Version: PHP 5.2.0 or newer - false, as it appears this should always say 7.0.4-beta, rather than the implied 7.0.4-stable.
 [2019-01-25 16:06 UTC] nikic@php.net
-Status: Open +Status: Wont fix
 [2019-01-25 16:06 UTC] nikic@php.net
opcache is bundled since PHP 5.5, i.e. it's always compatible with the PHP version it ships with. The ZendOpcache PECL package is unmaintained since then and I doubt anyone is going to update it to fix the specified version dependencies in package.xml (if it's possible to do that retroactively at all), so I'm going to mark this as Won't Fix.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 22:01:28 2024 UTC