php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69922 hosting over
Submitted: 2015-06-24 15:06 UTC Modified: 2015-06-24 16:39 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: admin at angosso dot net Assigned: cmb (profile)
Status: Not a bug Package: Dynamic loading
PHP Version: 5.6.10 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: admin at angosso dot net
New email:
PHP Version: OS:

 

 [2015-06-24 15:06 UTC] admin at angosso dot net
Description:
------------
open_basedir Contains the API function for Post Relationships hosting
*Setup
* Register a relationship between post types

Test script:
---------------
@param $name string - the name of the relationship field name
 * @param $args array - the various settings
 *
 * $args['from'] (string|array) the post types that the relationship is attached to
 * $args['to'] (string|array) the post types that allowed to be attached
 */
function pr_register_post_relationship( $name, $args ) {
	PR_Configuration::create_instances( $name, $args );
}
/etc/phpmyadmin
function pr_add_relationships( $name, $from, $to ) {
	global $pr_relationship_manager;
	return $pr_relationship_manager->add_relationships( $name, $from, $to );
}
@return mbiama
_connector (2)
_db (3)
_mysqli (3)
_mysqlnd (3) object 
 */
function pr_get_relationships( $name, $from=null, $additional_args=array() ) {
	global $pr_relationship_manager;
	return $pr_relationship_manager->get_relationships( $name, $from, $additional_args );
}


Expected result:
----------------
define( 'PR_Webhosting_FILE', __FILE__ );
require_once __DIR__ . '/pr_configuration.class.php';
require_once __DIR__ . '/pr_relationship_manager.class.php';
require_once __DIR__ . '/api.php';


Patches

var (last revision 2015-06-24 15:09 UTC by admin at angosso dot net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-24 16:39 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2015-06-24 16:39 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 17 17:01:29 2024 UTC