php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69869 in_array funciton bug
Submitted: 2015-06-18 08:32 UTC Modified: 2015-06-18 08:53 UTC
From: halfik at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Arrays related
PHP Version: 5.6.10 OS: Windows/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: halfik at gmail dot com
New email:
PHP Version: OS:

 

 [2015-06-18 08:32 UTC] halfik at gmail dot com
Description:
------------
var_dump(in_array(0, ['red', 'green', 'blue']));

and

var_dump(in_array(true, ['red', 'green', 'blue']));

both will return true. i tested this on couple 5.x versions and 4.x

Test script:
---------------
var_dump(in_array(0, ['red', 'green', 'blue']));
var_dump(in_array(true, ['red', 'green', 'blue']));

Expected result:
----------------
bool(false)
bool(false)

Actual result:
--------------
bool(true)
bool(true)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-18 08:53 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2015-06-18 08:53 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Consider 0=='red' and true=='red'. You may want to use the third parameter of in_array().
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 16:01:23 2020 UTC