|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69819 Builtinin server crashing when mbstring, xsl and mysql extension enabled
Submitted: 2015-06-13 12:53 UTC Modified: 2015-06-14 13:38 UTC
From: damir dot zelenika at gmail dot com Assigned: ab (profile)
Status: Closed Package: Built-in web server
PHP Version: 7.0.0alpha1 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: damir dot zelenika at gmail dot com
New email:
PHP Version: OS:


 [2015-06-13 12:53 UTC] damir dot zelenika at gmail dot com
Cannot start Builtin-in server when mbstring, xsl and mysql extensions enabled simultaneosly.
Tried with both x86 and x64 version.
Here is windows event log:

<Event xmlns="">
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <TimeCreated SystemTime="2015-06-13T12:23:21.000000000Z" /> 
  <Security /> 


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-13 14:05 UTC]
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2015-06-13 14:05 UTC]
I'm not able to reproduce this issue. However, when I start the
built-in webserver with these extensions enabled, I get:
| PHP Warning: PHP Startup: Unable to load dynamic library
| 'ext\php_mysql.dll'

That is to be expected, because the mysql extension has been
removed from PHP 7.0.0. In your case, it is possible that
php_mysql.dll from another PHP installation is used, which might
crash the webserver.

Please double-check that there's no other PHP installation in the
 [2015-06-13 14:26 UTC]
@damir, yeah, it's most likely as @cmb says. ext/mysql was removed, please do not try to use VC11 master (or any other) builds with the released alpha1. The ext/mysqli is what should be used.

 [2015-06-13 15:26 UTC] damir dot zelenika at gmail dot com
-Status: Feedback +Status: Assigned
 [2015-06-13 15:26 UTC] damir dot zelenika at gmail dot com
My mistake. It is not php_mysql but php_pdo_mysql.
There is no any php installation in PATH. I have included only these 3 extensions:


If I exclude any of them server is not crashing.
I have tested it as FastCGI module on Windows server 2008 R2 Standard and it is crashing too. There is not anything in php log. Only error:

   The FastCGI process exited unexpectedly 

in my browser.
 [2015-06-13 15:54 UTC]
@damir, are you running php-cgi as described in bug #69814 ? Which web server do you use?

 [2015-06-13 15:58 UTC]
-Status: Assigned +Status: Verified -Assigned To: cmb +Assigned To:
 [2015-06-13 15:58 UTC]
@ab Confirmed: the combination of mbstring, pdo_mysql (or any other
PDO driver) and xsl crashes the PHP built-in webserver (x86 and x64, NTS and TS).
 [2015-06-13 16:00 UTC]
@cmb, please post the BT.

 [2015-06-13 16:35 UTC] damir dot zelenika at gmail dot com
I'm testing on IIS7 as FastCGI module.

Downloaded php:
I'm getting the same error with 64bit nts version:

@cmb it is not only crashing as built-in web server but as IIS FastCGI module too.
 [2015-06-13 18:39 UTC]
@cmb iconv is an issue, either it's a bad library build or something in the module. Lets check.

 [2015-06-13 20:43 UTC]
@ab I still have not been able to get a BT. The *.pdbs in the
debug package[1] are not recognized by VS2015RC (when selecting
php7.pdb manually, I get "Dieser Ordner enthält keine passende

I also have not been able to build from the official
tar.gz/.bz[2]. When I extract these with 7zip I have spurious
"PaxHeaders.21358" directories in each folder, and VC11 fails
(error C2375: 'zendparse': Neudefinition; unterschiedliche Bindung

I can, however, build from master and from the Github zip of the
7.0.0alpha1 tag[3] with VC11. I cannot reproduce the crash there,

I'll try to set up a VC14 build environment.

[1] <>
[2] <>
[3] <>
 [2015-06-13 21:02 UTC]
@cmb, nailed it down a bit more now - mhash_init from MINIT in ext/hash corrupts the memory somehow.

 [2015-06-13 21:08 UTC]
@cmb, ah, just saw your last reply. If you debug a release build, unpack the .pdb somewhere and in visual studio go debug->options->debugging->symbols and set the path there. Or, your symbols are from another build, then coludn't match. But if the .pdb are in the same dirs as the actual bins, they should be found first.

If you build from source, just add --enable-debug, or if you want to debug a release build, add --enable-debug-pack .

 [2015-06-13 21:27 UTC]
@cmb, yeah, you'll need vc14, no vc11 anymore. And you can checkout just the php-7.0.0alpha1 tag. Please create a separate ticket if you're unable to build with the Windows sources from the zipball with vc14.

And, thanks for staying on this :)
 [2015-06-13 21:44 UTC]
-Assigned To: +Assigned To: ab
 [2015-06-14 10:41 UTC]
@cmb, @damir, please check the snapshot or latest master. This issue is most likely fixed in bug #69823.

 [2015-06-14 12:04 UTC]
I can confirm that the built-in server crash doesn't occur anymore
with the 69814 snapshot. @damir Can you test and report back wrt.
the IIS FastCGI module, please.

I'll create a separate ticket regarding the build problems.
 [2015-06-14 13:13 UTC] damir dot zelenika at gmail dot com
-Status: Verified +Status: Closed
 [2015-06-14 13:13 UTC] damir dot zelenika at gmail dot com
I've tested nts x64 as FastCGI.
It is not crashing anymore.

 [2015-06-14 13:38 UTC]
Thanks for checking the alpha1!
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Sep 27 08:05:51 2022 UTC