php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #69745 missing keywords definitions and mentions on lists
Submitted: 2015-06-01 22:53 UTC Modified: 2017-01-28 17:24 UTC
From: gbarros at yahoo-inc dot com Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 5.6.10RC1 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gbarros at yahoo-inc dot com
New email:
PHP Version: OS:

 

 [2015-06-01 22:53 UTC] gbarros at yahoo-inc dot com
Description:
------------
cannot find the definition for keywords such as 'self' or 'this'.

either via search or on the keywords list page
http://php.net/manual/en/reserved.keywords.php




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-28 17:24 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Type: Bug +Type: Documentation Problem -Assigned To: +Assigned To: cmb
 [2017-01-28 17:24 UTC] cmb@php.net
`self` is documented in the predefined classes section[1], and
`$this` is documented in the OOP basics section[2].

[1] <http://php.net/manual/en/reserved.classes.php>
[2] <http://php.net/manual/en/language.oop5.basic.php>
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Sep 28 08:01:25 2020 UTC