php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #697 can't require() files that start with a "."
Submitted: 1998-08-26 18:24 UTC Modified: 1998-09-19 15:11 UTC
From: cmv at privateworld dot com Assigned:
Status: Closed Package: Performance problem
PHP Version: 3.0.3 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cmv at privateworld dot com
New email:
PHP Version: OS:

 

 [1998-08-26 18:24 UTC] cmv at privateworld dot com
require (".filename.php3");

... will cause a parse error, even when the file exists and is valid PHP.  Renaming the file to "filename" works as expected.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-09-19 15:11 UTC] zeev
Unable to reproduce that, works fine here.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 27 13:01:25 2020 UTC