php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69660 make fails with compilation error
Submitted: 2015-05-19 11:06 UTC Modified: 2015-05-19 12:06 UTC
From: warren dot zaccone at ericsson dot net Assigned: cmb (profile)
Status: Duplicate Package: Compile Failure
PHP Version: 5.6.9 OS: Solaris 10 Sparc
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: warren dot zaccone at ericsson dot net
New email:
PHP Version: OS:

 

 [2015-05-19 11:06 UTC] warren dot zaccone at ericsson dot net
Description:
------------
make of 5.6.9 fails on Solaris 10 with the following error, my configure command follows below.     Server is httpd 2.4.12
thank you.

/bin/bash /usr/nmadev/package/install_apache_php/php-5.6.9/libtool --silent --preserve-dup-deps --mode=compile gcc -I/usr/nmadev/package/install_apache_php/php-5.6.9/ext/sqlite3/libsqlite -DSQLITE_ENABLE_FTS3=1 -DSQLITE_CORE=1 -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_THREADSAFE=1  -Iext/sqlite3/ -I/usr/nmadev/package/install_apache_php/php-5.6.9/ext/sqlite3/ -DPHP_ATOM_INC -I/usr/nmadev/package/install_apache_php/php-5.6.9/include -I/usr/nmadev/package/install_apache_php/php-5.6.9/main -I/usr/nmadev/package/install_apache_php/php-5.6.9 -I/usr/nmadev/package/install_apache_php/php-5.6.9/ext/date/lib -I/usr/nmadev/package/install_apache_php/php-5.6.9/ext/ereg/regex -I/usr/local/include/libxml2 -I/usr/local/apache/ssl/include -I/usr/local/include -I/usr/local/instantclient_11_2/sdk/include -I/usr/nmadev/package/install_apache_php/php-5.6.9/ext/sqlite3/libsqlite -I/usr/nmadev/package/install_apache_php/php-5.6.9/TSRM -I/usr/nmadev/package/install_apache_php/php-5.6.9/Zend  -D_POSIX_PTHREAD_SEMANTICS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT  -I/usr/local/include -g -O2 -DZTS  -c /usr/nmadev/package/install_apache_php/php-5.6.9/ext/sqlite3/libsqlite/sqlite3.c -o ext/sqlite3/libsqlite/sqlite3.lo
In file included from /usr/include/stdio.h:22,
                 from /usr/nmadev/package/install_apache_php/php-5.6.9/ext/sqlite3/libsqlite/sqlite3.c:8640:
/usr/include/sys/feature_tests.h:336:2: #error "Compiler or options invalid; UNIX 03 and POSIX.1-2001 applications      require the use of c99"
^Cmake: *** [ext/sqlite3/libsqlite/sqlite3.lo] Error 1

Test script:
---------------
configure --prefix=/usr/local/apache/lib --exec-prefix=/usr/local/apache --wit
h-apxs2=/usr/local/apache/bin/apxs --with-openssl=/usr/local/apache/ssl --with-curl=/usr/local --enable-sockets --enable-ftp --enable-soap --without-pear --with-oci8=instantclient,/usr/local/instantclient_11_2



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-05-19 12:05 UTC] warren dot zaccone at ericsson dot net
I solved this problem by adding CC=" gcc -std=gnu99"  before the configure.
 [2015-05-19 12:06 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2015-05-19 12:06 UTC] cmb@php.net
This is a duplicate of bug #67229. There is a workaround presented as well.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Mar 26 12:01:27 2019 UTC