php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #69641 Incorrect note for strip_tags()
Submitted: 2015-05-15 14:57 UTC Modified: 2015-05-15 15:05 UTC
From: brian at brianhogg dot com Assigned: cmb (profile)
Status: Duplicate Package: Strings related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: brian at brianhogg dot com
New email:
PHP Version: OS:

 

 [2015-05-15 14:57 UTC] brian at brianhogg dot com
Description:
------------
---
From manual page: http://www.php.net/function.strip-tags
---
The note documentation in the documentation for $allowed_tags reads:

In PHP 5.3.4 and later, you will also need to include the self-closing XHTML tag to strip these from str. For example, to strip both <br> and <br/>, you should use:

but that param is to allow, not to strip. It should probably read something like:

In PHP 5.3.4 and later, you will also need to include the self-closing XHTML tag to allow these in str. For example, to allow both <br> and <br/>, you should use:


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-05-15 15:05 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: Documentation problem +Package: Strings related -Assigned To: +Assigned To: cmb
 [2015-05-15 15:05 UTC] cmb@php.net
Duplicate of bug #69584.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 18 21:01:32 2024 UTC