php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69618 'IS_CONSTANT_ARRAY' undeclared (first use in this function)
Submitted: 2015-05-11 06:43 UTC Modified: 2015-05-11 16:59 UTC
Votes:5
Avg. Score:4.2 ± 1.0
Reproduced:4 of 4 (100.0%)
Same Version:3 (75.0%)
Same OS:0 (0.0%)
From: rosenberger at taoweb dot at Assigned:
Status: Wont fix Package: APC (PECL)
PHP Version: 5.6Git-2015-05-11 (Git) OS: OpenSUSE 13.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rosenberger at taoweb dot at
New email:
PHP Version: OS:

 

 [2015-05-11 06:43 UTC] rosenberger at taoweb dot at
Description:
------------
Hello 

not able to compile APC. 3.1.13 on PHP 5.6.1


 make
/bin/sh /home/torsten/APC-3.1.13/libtool --mode=compile cc  -I. -I/home/torsten/APC-3.1.13 -DPHP_ATOM_INC -I/home/torsten/APC-3.1.13/include -I/home/torsten/APC-3.1.13/main -I/home/torsten/APC-3.1.13 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /home/torsten/APC-3.1.13/apc.c -o apc.lo 
libtool: compile:  cc -I. -I/home/torsten/APC-3.1.13 -DPHP_ATOM_INC -I/home/torsten/APC-3.1.13/include -I/home/torsten/APC-3.1.13/main -I/home/torsten/APC-3.1.13 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /home/torsten/APC-3.1.13/apc.c  -fPIC -DPIC -o .libs/apc.o
/home/torsten/APC-3.1.13/apc.c: In function 'apc_search_paths':
/home/torsten/APC-3.1.13/apc.c:352:5: warning: passing argument 2 of 'php_stream_locate_url_wrapper' from incompatible pointer type [enabled by default]
     wrapper = php_stream_locate_url_wrapper(filename, &path_for_open, 0 TSRMLS_CC);
     ^
In file included from /usr/include/php5/main/php.h:398:0,
                 from /home/torsten/APC-3.1.13/apc.h:61,
                 from /home/torsten/APC-3.1.13/apc.c:34:
/usr/include/php5/main/php_streams.h:549:28: note: expected 'const char **' but argument is of type 'char **'
 PHPAPI php_stream_wrapper *php_stream_locate_url_wrapper(const char *path, const char **path_for_open, int options TSRMLS_DC);
                            ^
/home/torsten/APC-3.1.13/apc.c:416:20: warning: assignment discards 'const' qualifier from pointer target type [enabled by default]
         exec_fname = zend_get_executed_filename(TSRMLS_C);
                    ^
/bin/sh /home/torsten/APC-3.1.13/libtool --mode=compile cc  -I. -I/home/torsten/APC-3.1.13 -DPHP_ATOM_INC -I/home/torsten/APC-3.1.13/include -I/home/torsten/APC-3.1.13/main -I/home/torsten/APC-3.1.13 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /home/torsten/APC-3.1.13/php_apc.c -o php_apc.lo 
libtool: compile:  cc -I. -I/home/torsten/APC-3.1.13 -DPHP_ATOM_INC -I/home/torsten/APC-3.1.13/include -I/home/torsten/APC-3.1.13/main -I/home/torsten/APC-3.1.13 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /home/torsten/APC-3.1.13/php_apc.c  -fPIC -DPIC -o .libs/php_apc.o
/bin/sh /home/torsten/APC-3.1.13/libtool --mode=compile cc  -I. -I/home/torsten/APC-3.1.13 -DPHP_ATOM_INC -I/home/torsten/APC-3.1.13/include -I/home/torsten/APC-3.1.13/main -I/home/torsten/APC-3.1.13 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /home/torsten/APC-3.1.13/apc_cache.c -o apc_cache.lo 
libtool: compile:  cc -I. -I/home/torsten/APC-3.1.13 -DPHP_ATOM_INC -I/home/torsten/APC-3.1.13/include -I/home/torsten/APC-3.1.13/main -I/home/torsten/APC-3.1.13 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /home/torsten/APC-3.1.13/apc_cache.c  -fPIC -DPIC -o .libs/apc_cache.o
/home/torsten/APC-3.1.13/apc_cache.c: In function '_apc_cache_user_update':
/home/torsten/APC-3.1.13/apc_cache.c:818:63: error: 'IS_CONSTANT_INDEX' undeclared (first use in this function)
             switch(Z_TYPE_P((*slot)->value->data.user.val) & ~IS_CONSTANT_INDEX) {
                                                               ^
/home/torsten/APC-3.1.13/apc_cache.c:818:63: note: each undeclared identifier is reported only once for each function it appears in
/home/torsten/APC-3.1.13/apc_cache.c:820:22: error: 'IS_CONSTANT_ARRAY' undeclared (first use in this function)
                 case IS_CONSTANT_ARRAY:
                      ^
Makefile:186: recipe for target 'apc_cache.lo' failed
make: *** [apc_cache.lo] Error 1

BR/Torsten


Expected result:
----------------
should run aon PHP 5.6

Actual result:
--------------
not able to build APC

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-05-11 06:48 UTC] kalle@php.net
-Status: Open +Status: Wont fix
 [2015-05-11 06:48 UTC] kalle@php.net
APC support have been discontinued infavor of opcache that comes with 5.6, therefore if you wish to have 5.6 support, you need to modify the source yourself (sadly) :(
 [2015-05-11 07:22 UTC] rosenberger at taoweb dot at
Hello Kalle

yes, now there is opcache, but there are some more features in APC.
Caching SQL results or partiality content for speed improvement 
as show in all the PHP presentations.


BR/Torsten
 [2015-05-11 08:13 UTC] pajoye@php.net
You can use apcu or wincache (on Windows) for user cache.
 [2015-05-11 16:59 UTC] cmb@php.net
> APC support have been discontinued infavor of opcache that comes with 5.6

It seems to be reasonable to document this fact. See also bug #69302.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 18:01:23 2020 UTC