php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #69608 fwrite and magic_quotes_runtime
Submitted: 2015-05-08 19:34 UTC Modified: 2017-09-12 10:38 UTC
From: cmb@php.net Assigned: cmb (profile)
Status: Not a bug Package: Filesystem function related
PHP Version: Irrelevant OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cmb@php.net
New email:
PHP Version: OS:

 

 [2015-05-08 19:34 UTC] cmb@php.net
Description:
------------
---
From manual page: http://www.php.net/function.fwrite
---

The documentation states:

> Note that if the length argument is given, then the
> magic_quotes_runtime configuration option will be ignored and no
> slashes will be stripped from string.

However, when magic_quotes_runtime is On, writing would not
*strip*, but rather *add* slashes (backslashes might be the better
wording).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-09-12 10:38 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2017-09-12 10:38 UTC] cmb@php.net
> However, when magic_quotes_runtime is On, writing would not
> *strip*, but rather *add* slashes […]

No, it does indeed strip, see <https://3v4l.org/KLqJ9>.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Nov 27 22:01:25 2020 UTC