php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69543 cannot install latest timezonedb
Submitted: 2015-04-28 11:29 UTC Modified: 2015-08-21 09:09 UTC
Votes:5
Avg. Score:3.8 ± 1.0
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:2 (40.0%)
From: leolistas at solutti dot com dot br Assigned: derick (profile)
Status: Closed Package: timezonedb (PECL)
PHP Version: 5.6.8 OS: CentOS 6.6 x86_64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: leolistas at solutti dot com dot br
New email:
PHP Version: OS:

 

 [2015-04-28 11:29 UTC] leolistas at solutti dot com dot br
Description:
------------
I cannot install latest timezonedb (2015.4) on PHP 5.6.7 and 5.6.8. Error says it's not compatible. Problem didnt happen with 2015.2 and PHP 5.6.7, it installed and it working just fine.

package.xml from 2015.4 seems to have a LOT of <exclude></exclude> lines, excluding basically all PHP versions. I really dont think this is correct, it really seems to be a bug. Should it be <include> tags ??

Test script:
---------------
[root@mail php56]# php -v
PHP 5.6.8 (cli) (built: Apr 28 2015 08:00:20)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies

[root@mail php56]# pecl install timezonedb
pecl/timezonedb is not compatible with PHP version 5.6.8
No valid packages found
install failed


Expected result:
----------------
i was expecting it to be installed with no problems.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-04-28 16:00 UTC] mark dot dissington at etisoftware dot co dot uk
The same goes for CentOS 6.6 running php-5.3.3-40.el6_6.x86_64

Looks like a load of pre-requisites have been added for some reason blocking installation. Funny when the point of the TimeZoneDB package is to update old PHP versions to use the latest Timezone Data correctly.

Pecl error:
Update of Channel "pecl.php.net" succeeded
pecl/timezonedb requires PHP (version >= 5.4.41, excluded versions: 5.5.0, 5.5.1, 5.5.2, 5.5.3, 5.5.4, 5.5.5, 5.5.6, 5.5.7, 5.5.8, 5.5.9, 5.5.10, 5.5.11, 5.5.12, 5.5.13, 5.5.14, 5.5.15, 5.5.16, 5.5.17, 5.5.18, 5.5.19, 5.5.20, 5.5.21, 5.5.22, 5.5.23, 5.5.24, 5.6.0, 5.6.1, 5.6.2, 5.6.3, 5.6.4, 5.6.5, 5.6.6, 5.6.7, 5.6.8), installed version is 5.3.3
No valid packages found
 [2015-04-28 19:57 UTC] leolistas at solutti dot com dot br
as an easy workaround, i installed timezonedb with '--ignore-errors' option. It installed and is working just fine, as expected, on PHP 5.6.8:

pecl install --ignore-errors  timezonedb
 [2015-04-28 22:15 UTC] cmb@php.net
-Status: Open +Status: Verified -Assigned To: +Assigned To: derick
 [2015-04-28 22:15 UTC] cmb@php.net
There is most certainly something wrong. As it is now, the package
requires 5.4.41, 5.5.25, 5.6.9 or 7.x.y, none of which have been
released yet.

Derick, can you please have a look at this issue.
 [2015-04-29 07:24 UTC] mark dot dissington at etisoftware dot co dot uk
Using the --ignore-errors option on PHP 5.3.3 latest CentOS/Redhat patched version also installs fine.
 [2015-07-07 10:10 UTC] mark dot dissington at etisoftware dot co dot uk
This is still an issue with the 2015.5 release.
 [2015-08-20 14:14 UTC] mark dot dissington at etisoftware dot co dot uk
Looks like the 2015.6 release has resolved this. Working on both CentOS 5 and 6 fully patched
 [2015-08-21 09:09 UTC] derick@php.net
You're right, 2015.6 is fixing this. Sorry for not closing this report!
 [2015-08-21 09:09 UTC] derick@php.net
-Status: Verified +Status: Closed
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Nov 14 11:01:25 2018 UTC