php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #69499 DateTime::createFromFormat() documentation doesn't mention that '+' (and '|') mo
Submitted: 2015-04-21 20:19 UTC Modified: 2015-09-04 00:01 UTC
From: antrik at users dot sf dot net Assigned: cmb (profile)
Status: Closed Package: Date/time related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: antrik at users dot sf dot net
New email:
PHP Version: OS:

 

 [2015-04-21 20:19 UTC] antrik at users dot sf dot net
Description:
------------
---
From manual page: http://www.php.net/datetime.createfromformat
---

The manual page doesn't mention anywhere that the '+' and '|' modifiers are not
available in older PHP versions, including at least 5.3.3. (There is a
user-contributed note mentioning that '|' works starting with 5.3.7 -- might be
same for '+'?.) This should be mentioned in the descriptions of these
modifiers, and/or in the changelog. It cost us several hours figuring out why
our code fails mysteriously for one of our users...



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-04-22 12:19 UTC] cmb@php.net
-Status: Open +Status: Verified -Package: Documentation problem +Package: Date/time related
 [2015-04-22 12:19 UTC] cmb@php.net
Thank you for your bug report. Indeed, the | format character is
available as of PHP 5.3.7[1], and the + format character is
available as of PHP 5.3.9[2].

[1] <http://3v4l.org/8hIvc>
[2] <http://3v4l.org/B16M6>
 [2015-09-03 23:54 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2015-09-03 23:54 UTC] cmb@php.net
I have to correct myself. The + modifier is available as of PHP
5.3.9 indeed, what has to be documented. However, the | modifier
is available as of PHP 5.3.0, but due to a bug didn't work
correctly in a trailing position until PHP 5.3.7. Usually we don't
document behavior caused by bugs in the manual proper, but
respective information is available via the changelog.
 [2015-09-04 00:01 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=337743
Log: added changelog (fixes #69499)
 [2015-09-04 00:01 UTC] cmb@php.net
-Status: Verified +Status: Closed
 [2015-09-04 00:01 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 20:04:13 2023 UTC