php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69355 Stuck in making of PHP-5.3.x with Generating phar.php
Submitted: 2015-04-02 11:28 UTC Modified: 2015-04-03 08:06 UTC
From: ahyu at foxmail dot com Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: Irrelevant OS: CentOS 6.5 x86_64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ahyu at foxmail dot com
New email:
PHP Version: OS:

 

 [2015-04-02 11:28 UTC] ahyu at foxmail dot com
Description:
------------
We're installing PHP-5.3.x on our Server.
The OS is CentOS 6.5 x86_64.
We've settled all the problems and errors occurred during configuring and make it successful.
It seemed good when we entered 'make' until it was stuck on 'Generating phar.php'.
We waited and waited, but it seemed no more information updated.
It was halted on.
We had nothing to do but change the version of PHP, almost all PHP-5.3.x, but it was no use.
We choose PHP-5.3.x and below because the program we will run on it was programmed for PHP-5.3 below.
We've also searched on Search engine for a long time, but got no solution.
We hope somebody here could offer some help.
Thanks.

Test script:
---------------
# ./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php/etc --with-apxs2=/usr/local/apache/bin/apxs --with-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config --with-gd=/usr/local/gd2 --with-libxml-dir=/usr/local/libxml2 --with-freetype-dir=/usr/local/freetype --with-mcrypt=/usr/local/libmcrypt --with-openssl=/usr/local/openssl --with-jpeg-dir=/usr/local/jpeg --with-png-dir=/usr/local/libpng --with-zlib --with-zlib-dir=/usr/local/zlib --with-gettext --with-curl=/usr/local/curl --with-ldap=/usr/local/ldap --with-iconv --enable-gd-native-ttf --enable-ftp --enable-mbstring --enable-embed --enable-calendar --enable-magic-quotes --enable-sockets --enable-sysvsem --enable-sysvshm --enable-sysvmsg --enable-pcntl --enable-shmop 
# make

Actual result:
--------------
Compiling paused as below for a long time:

Zend/zend_execute_API.lo Zend/zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_exceptions.lo Zend/zend_strtod.lo Zend/zend_gc.lo Zend/zend_closures.lo Zend/zend_float.lo Zend/zend_objects.lo Zend/zend_object_handlers.lo Zend/zend_objects_API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/php_cli_readline.lo main/internal_functions_cli.lo -lcrypt -lcrypt -lrt -lmysqlclient_r -lmcrypt -lltdl -lldap -llber -lgd -lfreetype -lpng -lz -ljpeg -lssl -lcrypto -lcurl -lz -lssl -lcrypto -lm -ldl -lnsl -lxml2 -lm -ldl -lcurl -lxml2 -lm -ldl -lmysqlclient_r -lz -lcrypt -lnsl -lm -lxml2 -lm -ldl -lcrypt -lxml2 -lm -ldl -lxml2 -lm -ldl -lxml2 -lm -ldl -lcrypt  -o sapi/cli/php
Generating phar.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-04-02 11:32 UTC] ahyu at foxmail dot com
-Summary: PHP-5.3.x +Summary: Stuck in making of PHP-5.3.x with Generating phar.php
 [2015-04-02 11:32 UTC] ahyu at foxmail dot com
Stuck in making of PHP-5.3.x with Generating phar.php
 [2015-04-02 21:40 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-04-02 21:40 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

> We hope somebody here could offer some help.

A bug tracker is no support forum. Please consider to contact one
of the support channels listed on http://php.net/support.php. :)
 [2015-04-03 07:01 UTC] ahyu at foxmail dot com
Thanks for your reply.
We wanna know how long does it take for compiling normally?
Thanks.
 [2015-04-03 07:26 UTC] nikic@php.net
Generating the phar should be pretty instant. If it takes a significant amount of time, there's likely an infinite loop somewhere. I'd suggest you to just abort that part (it's non-essential to the build) and see if "make test" works.

In any case, PHP 5.3 is no longer supported, so even if there's a bug here on PHPs side, we will not be able to fix it.
 [2015-04-03 08:06 UTC] ahyu at foxmail dot com
Thanks for your kindness.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Apr 05 02:01:23 2020 UTC