php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #69242 Add PHP7 support to uploadprogress
Submitted: 2015-03-15 23:50 UTC Modified: 2020-01-27 16:19 UTC
Votes:10
Avg. Score:4.1 ± 0.9
Reproduced:9 of 9 (100.0%)
Same Version:6 (66.7%)
Same OS:4 (44.4%)
From: github at ehrhardt dot nl Assigned: ramsey (profile)
Status: Closed Package: uploadprogress (PECL)
PHP Version: master-Git-2015-03-15 (Git) OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: github at ehrhardt dot nl
New email:
PHP Version: OS:

 

 [2015-03-15 23:50 UTC] github at ehrhardt dot nl
Description:
------------
I have made some changes in the uploadprogress sources to add PHP7 support. Please take a look at https://github.com/Jan-E/uploadprogress

Test script:
---------------
I tested it on Windows with PHP 7 x86 loaded as mod_php. It ran fine.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-15 23:54 UTC] github at ehrhardt dot nl
-Summary: Add PHP7 support +Summary: Add PHP7 support to uploadprogress
 [2015-03-15 23:54 UTC] github at ehrhardt dot nl
Changed the title to make it more descriptive
 [2017-03-08 18:55 UTC] mikes dot slywka at royalroads dot ca
Tested on opensuse 13.1 (x86_64) with PHP 7.0.16 and it worked for me.

Thanks!

Mike
 [2017-03-08 22:40 UTC] github at ehrhardt dot nl
-Status: Open +Status: Closed
 [2017-03-08 22:40 UTC] github at ehrhardt dot nl
I did not even know this bugreport was still open
 [2017-07-15 12:10 UTC] marc dot bau at gmx dot net
Can someone create a new release, please? I cannot install this PHP7 compatible version.
 [2017-09-21 12:12 UTC] cmb@php.net
-Status: Closed +Status: Re-Opened
 [2017-09-21 12:12 UTC] cmb@php.net
Please keep this ticket open (or maybe suspend it) until the request is
resolved.

Jan, have you contacted one of the PECL/uploadprogress maintainers regarding
PHP 7 compatibility?
 [2017-09-21 23:19 UTC] github at ehrhardt dot nl
Sure. They merged a PR:
https://github.com/php/pecl-php-uploadprogress/commits/master
http://git.php.net/?p=pecl/php/uploadprogress.git
 [2017-09-22 07:16 UTC] chregu@php.net
This https://secure.php.net/manual/en/session.upload-progress.php is the official way to track the upload progress since about PHP 5.3

No one is really working on this extension anymore.
 [2017-09-22 23:20 UTC] cmb@php.net
> No one is really working on this extension anymore.

Thanks!  However, is this not supposed to be noted on its PECL page[1], similar
to PECL/SQLlite[2]?

[1] <https://pecl.php.net/package/uploadprogress>
[2] <https://pecl.php.net/package/SQLite>
 [2017-10-24 09:00 UTC] kalle@php.net
-Status: Re-Opened +Status: Suspended
 [2017-10-24 09:00 UTC] kalle@php.net
This package has not had any releases for 6 years, so I'm gonna suspend it, any new maintainer that decides to pick this up can re-open this ticket.
 [2020-01-26 01:10 UTC] ramsey@php.net
-Status: Suspended +Status: Open -Assigned To: +Assigned To: ramsey
 [2020-01-27 16:19 UTC] ramsey@php.net
-Status: Assigned +Status: Closed
 [2020-01-27 16:19 UTC] ramsey@php.net
PHP 7 (and 8) support is now implemented in uploadprogress. Please upgrade to version 1.1.2 or later.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 22:01:24 2020 UTC