php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69222 Support PKCS#7 padding
Submitted: 2015-03-11 15:23 UTC Modified: 2017-01-10 10:15 UTC
From: dan at zaph dot com Assigned: leigh (profile)
Status: Not a bug Package: mcrypt related
PHP Version: 5.6.6 OS: all?
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dan at zaph dot com
New email:
PHP Version: OS:

 

 [2015-03-11 15:23 UTC] dan at zaph dot com
Description:
------------
PKCS#7 is the industry standard for encryption padding. mcrypt does not support it, instead uses a no-standard null padding which does not work for binary data that might have a trailing 0 byte.

This default non-standard padding causes substantial interoperability problems. Is that what the php developers want?

Proposed solution: Add PKCS#7 padding option or remove mcrypt from distribution.

Or perhaps you guys are just lazy open source jerks that want to create interoperability problems for php users. OK, that made you mad, just like you make mcrypt used mad. Nice.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-14 23:30 UTC] leigh@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: leigh
 [2016-12-14 23:30 UTC] leigh@php.net
Closing because I'm such a lazy open source jerk I can't be bothered to tell the poster this isn't the place for libmcrypt feature requests.
 [2017-01-10 10:15 UTC] leigh@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 18 18:03:39 2021 UTC