php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6922 Cannot load /etc/httpd/modules/libphp4.so into server
Submitted: 2000-09-28 06:27 UTC Modified: 2001-06-01 15:26 UTC
From: kiment at addr dot com Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 4.0.2 OS: Redhat 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kiment at addr dot com
New email:
PHP Version: OS:

 

 [2000-09-28 06:27 UTC] kiment at addr dot com
I have the following configuration options for dynamic php:

sh ./configure --prefix=/usr \
        --without-gd \
        --with-apxs=/usr/sbin/apxs \
        --enable-versioning \
        --with-config-file-path=/usr/lib \
        --enable-debugger=yes \
        --enable-safe-mode \
        --with-exec-dir=/usr/bin \
        --with-mysql \
        --with-oci8=/u01/app/oracle/product/8.1.5 \
        --with-pdflib=/usr \
        --with-system-regex \
        --enable-track-vars \
        --with-ttf \
        --with-zlib \
        --with-wddx


This configures and compiles fine.


I configured the httpd.conf files with the appropriate module paths...

LoadModule php4_module        modules/libphp4.so
AddModule mod_php4.c

Since I'm running oracle 8.1.5.01(with patches) for linux, I even made sure
the LD_LIBRARY_PATH was available for apache

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/u01/app/oracle/product/8.1.5/lib
export LD_LIBRARY_PATH

Then I start apache...
/usr/local/apache/bin/apachectl start

However, this is the error I get every time.

[root@redora init.d]# ./httpd start
Starting httpd: Syntax error on line 874 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp
4.so: undefined symbol: php_regcomp
                                                           [FAILED]
[root@redora init.d]#


I believe this problem involves how php4's routine interfaces with the oracle sqlplus calls
although I'm not too sure exactly where it breaks.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-06 11:13 UTC] derick@php.net
Can you try this with php 4.0.5 and see if this problem still exists?
 [2001-06-01 15:26 UTC] sniper@php.net
No feedback, assumed fixed in PHP 4.0.5.

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Sep 28 13:01:23 2020 UTC