php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69192 Unable to initialize mbstring module
Submitted: 2015-03-05 11:33 UTC Modified: 2015-03-05 12:38 UTC
From: druhypokus at gmail dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.5.22 OS: Windows 7 Enterprise
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: druhypokus at gmail dot com
New email:
PHP Version: OS:

 

 [2015-03-05 11:33 UTC] druhypokus at gmail dot com
Description:
------------
PHP running as built-in web server is unable to load php_mbstring.dll.

Starting command:

php -d extension=C:\php\ext\php_mbstring.dll -S localhost:80

Message displayed:

[Thu Mar 05 12:27:01 2015] PHP Warning:  PHP Startup: mbstring: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP 5.5.22 Development Server started at Thu Mar 05 12:27:01 2015
Listening on http://localhost:80



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-05 12:38 UTC] reeze@php.net
-Status: Open +Status: Not a bug
 [2015-03-05 12:38 UTC] reeze@php.net
You need to load the extensions compiled with proper PHP version. I mean you should load an extension suitable for you PHP's version.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 03:01:29 2024 UTC